0

I have an SSD dual booted with windows 11 and manjaro. I installed an HDD today, now grub won't show up. I reinstalled grub using live usb but every time my PC directly boots into windows. The boot sequence is also fine.

lsblk                                           ✔ 
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
loop0    7:0    0  32.7M  1 loop /run/miso/sfs/livefs
loop1    7:1    0 896.5M  1 loop /run/miso/sfs/mhwdfs
loop2    7:2    0   1.4G  1 loop /run/miso/sfs/desktopfs
loop3    7:3    0 739.3M  1 loop /run/miso/sfs/rootfs
sda      8:0    0 931.5G  0 disk 
└─sda1   8:1    0 931.5G  0 part 
sdb      8:16   0 238.5G  0 disk 
├─sdb1   8:17   0   650M  0 part 
├─sdb2   8:18   0    16M  0 part 
├─sdb3   8:19   0 104.8G  0 part 
├─sdb4   8:20   0   670M  0 part 
├─sdb5   8:21   0  39.6G  0 part 
├─sdb6   8:22   0   954M  0 part 
└─sdb7   8:23   0  91.9G  0 part 
sdc      8:32   1   7.6G  0 disk /run/miso/bootmnt
├─sdc1   8:33   1   3.1G  0 part 
└─sdc2   8:34   1     4M  0 part 

Idk if this is necessary information but sdb7 is where my manjaro is installed, sdb1 is EFI. sda1 is new hdd.

7
  • I reinstalled grub using live usb - perhaps you did it wrong? Jan 24, 2023 at 5:12
  • Hmm I'm not sure, I just remove the hdd and grub works. Why is it even necessary to fix grub again after just adding extra storage? I am so confused.
    – sarjyantS
    Jan 24, 2023 at 5:52
  • 1
    perhaps it's your BIOS (UEFI) that is booting from the wrong drive? Jan 24, 2023 at 6:01
  • Hmm.. I have no idea. Can you help fix it?
    – sarjyantS
    Jan 24, 2023 at 7:06
  • 1
    To check which drive is being booted you need to get into the BIOS/UEFI. To do that you press a key when the computer is first booted but before the windows animation starts. The key to press varies by manufacturer. Typically it’s del, F2, F10 or F12. You will have to look that up yourself or give us more details about your computer or motherboard model. In the BIOS/UEFI you should find a setting for that. Your new drive is sda which is normally the first drive. This may be confusing the issue. You need to check where the grub.cfg file is located and ensure that is where you install grub to.
    – PonJar
    Jan 24, 2023 at 10:02

1 Answer 1

2

I added new boot option in bios and manually set the grubx64efi, that fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .