I am using EndeavorOS with i3 and am trying to put stuff on a thumb drive, but Thunar file manager isn't seeing it. When I run fdisk -l and lsusb I see the thumb drive, but it doesn't show up in Thunar.

I tried mount /dev/sdc, but I get the response mount: /dev/sdc: can't find in /etc/fstab. I also tried chmod -R 0777 /dev/sdc which runs without error but nothing changes. I am not really sure what to do at this point. Below is the useful bit of my output for fdisk and lsusb.

lsusb: Bus 001 Device 005: ID 154b:00ed PNY USB 3.1 FD


Disk /dev/sdc: 28.91 GiB, 31042043904 bytes, 60628992 sectors
Disk model: USB 3.1 FD      
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 304380E4-7F38-4C05-9262-5A90B5275272
  • Are there no partitions on the thumb drive or is the part only missing in your fdisk output?
    – Freddy
    Jan 20 at 19:09
  • It doesn't have any partitions that I'm seeing.
    – Hercislife
    Jan 20 at 19:11
  • Then you need to create at least one. Maybe use gparted to create a partition and filesystem.
    – Freddy
    Jan 20 at 19:13
  • @Freddy You were correct. I someone totally missed that it didn't have any partitions. Feel free to open an answer so I can mark it correct! Thank you for the help.
    – Hercislife
    Jan 20 at 19:29
  • Please feel free to self-answer your question. You need the reputation more than I do.
    – Freddy
    Jan 20 at 19:33

1 Answer 1


With help from Freddy in the comments I found the issue was that the thumb drive didn't have a partition. Creating one with GParted solved the problem!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .