0

Just installed Network Manager on Void Linux. I am unable to activate connections with my normal user: when i try to, nmcli returns Error: Connection activation failed: Not authorized to control networking. It works with root. According to the void handbook, it is necessary to add an user to the network group in order for it to be able to use it. But i get the same error after adding my user to that group and rebooting.

3
  • Have you tried rebooting? Jan 19, 2023 at 20:18
  • @ArtemS.Tashkinov Yes, as stated in the last word of my question.
    – Carla_
    Jan 19, 2023 at 21:03
  • Sorry for being inattentive. No ideas then. Maybe you could switch to a distro which uses NM natively. E.g. in Fedora I'm not a member of any groups, yet I can manage NM just fine. Jan 19, 2023 at 21:08

1 Answer 1

0

Seems like the issue was not having polkit installed. After installing it, it now works as intended. Strangely, there is no mention of polkit in the NetworkManager page of Void's handbook, or in any other page except one about libvirt.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .