0

The latest Samsung driver from the vendor page

General: https://support.hp.com/hk-en/drivers/selfservice/samsung-xpress-sl-m2070-laser-multifunction-printer-series/16450377

Details of the driver: https://support.hp.com/hk-en/drivers/selfservice/swdetails/samsung-xpress-sl-m2070-laser-multifunction-printer-series/16450377/swItemId/fp-191129-2

uld_V1.00.39_01.17.tar.gz

does not list any appropriate driver ppd file under cups (http://localhost:631/admin) or in the ubuntu "Select Printer Driver" menu:

enter image description here

When printing I get error messages like, when using the wrong driver:

SPL ERROR - Please use the proper driver.
     POSITION : 0x0 (0)
     SYSTEM : h6fwsim/xl_op
     LINE : 206
     VERSION : SPL 5.73 06-16-2013
     ERROR CODE : 11-1113

or

%!
  userdict dup(\004)cvn{}put (\004\004)cvn{}put
                                               /cups_handleerror {
                                                                    $error /ne

Which ppd file should or could I use instead?

1 Answer 1

1

I found this driver to work through trial and error.

Choose the scx3200.ppd file or in the "Select Printer Driver" menu choose

  1. Settings
  2. Printers enter image description here
  3. Add Button
  4. Await detection of M2070 (Model Generic Text-Only Printer)
  5. Click the settings wheel (enter image description here)
  6. Printer Details
  7. Select from Database...
  8. Await "Loading drivers database..."
  9. Select "Samsung"
  10. Select "Samsung SCX 3200, 2.0.0"
  11. Select the "Select" button

enter image description here

3
  • Did scanning works for you with this driver?
    – widget
    Commented Mar 7, 2023 at 8:40
  • Scanning via USB with simple-scan works, if I scan with colors on 300 dpi. When scanning with 150 dpi it fails sometimes to scan the whole page and has some kind of interruption in the forward movement of the scanner.
    – swiesend
    Commented Mar 9, 2023 at 6:39
  • Thanks, gonna test it again as most probably I need to restart system and then try as I need to do it after reinstalling uld drivers or sometimes when updating packages which are restarting udev.
    – widget
    Commented Mar 10, 2023 at 7:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .