2

My system keeps getting wedged because an scdaemon process has been spawned that has grown to consume all free memory on the computer. (I do not use, and have never used, smart cards in the vicinity of this system, so scdaemon shouldn't be running at all.)

I could implement something like a cronjob that runs pkill scdaemon every five seconds, but I'd rather find and destroy the root issue that's causing this behavior.

What files can I check and what tools can I use to track down why this daemon keeps getting started? I've done a pstree and the most I've been able to determine is that they're getting started by gpg-agent, which hasn't helped. I haven't found any log that's been able to shed some light on this.

  • For reference, the man page is here: linux.die.net/man/1/scdaemon – slm Apr 21 '13 at 14:23
  • Please always mention the version of GnuPG (and the OS) so that it is possible to replicate the problem. I can look up what version Arch linux ships. If there are any patches in the Arch version of GnupG it would also be good to know them. – user38293 May 1 '13 at 12:16
3

To stop gpg-agent from starting scdaemon, simply add

disable-scdaemon

to your gpg-agent configuration file (usually ~/.gnupg/gpg-agent.conf). This file can contain any long option you can pass to gpg-agent without the two leading dashes as described in gpg-agent(1), section "FILES".

Of course, informing the GnuPG guys about your problem is also a good idea so it can be fixed!

  • 1
    Do you mean ~/.gnupg/gpg-agent.conf? – Stuart P. Bentley Apr 25 '13 at 16:38
  • I've filed an issue at bugs.g10code.com/gnupg/issue1491 - I'm upvoting this answer (and have implemented its recommendation), but I'm not marking it as accepted because it doesn't answer the original question of why this is happening. – Stuart P. Bentley Apr 25 '13 at 17:37
0

I found these instructions for managing the scdaemon through gpg-agent. The client tool to do this is called gpg-connect-agent.

To stop SCDAEMON and let it exit, type:

% gpg-connect-agent "SCD KILLSCD" "SCD BYE" /bye

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.