3

I downloaded WSL (Windows Subsystem for Linux) and tried to run an AppImage, but received an error message that said

AppImage needs FUSE to run

When I tried the --appimage-extract and --appimage-extract-and-run options, neither of them worked. It seems that FUSE is not supported in WSL.

How can I run an AppImage on WSL if it requires FUSE and FUSE is not supported in WSL?

5
  • so you know you can't use FUSE, and it says it needs FUSE: What's the question? You forgot to include an actual sentence that states a question. Commented Jan 9, 2023 at 18:30
  • @MarcusMüller Could be a language barrier - I'm going to guess that it should be something like, "Do I understand that ... ?" But I definitely agree that it needs clarification. Commented Jan 9, 2023 at 20:35
  • 1
    @NotTheDr01ds I hopefully cleaned it up, if the original poster reads the edit and thinks it's not correct, then they should simply make it correct by a further edit.
    – Kusalananda
    Commented Jan 9, 2023 at 20:49
  • 1
    And @SebastianViollaz - Just a heads-up that FUSE is supported in WSL2 (but not WSL1). I've never tried AppImages though. Commented Jan 9, 2023 at 21:11
  • @MarcusMüller The post is edited now Commented Jan 10, 2023 at 13:38

1 Answer 1

2

You don't mention which Ubuntu version you are using, but I'm guessing Ubuntu 22.04 since that release doesn't include FUSE by default. See this answer on Ask Ubuntu. I tested with the KeePassXC AppImage on WSL on both Ubuntu 20.04 and 22.04. It works fine on 20.04, but I get the same error as you on 22.04. To quote the entire error for searchability:

dlopen(): error loading libfuse.so.2

AppImages require FUSE to run.
You might still be able to extract the contents of this AppImage
if you run it with the --appimage-extract option.
See https://github.com/AppImage/AppImageKit/wiki/FUSE
for more information

Again, this isn't a WSL issue -- You'd see the same thing on any installation of Ubuntu 22.04.

The solution is straightforward:

sudo apt install libfuse2

However, on WSL you may find that you need additional dependencies for graphical apps, since the WSL Ubuntu distribution is based on Ubuntu Server and doesn't include graphical libraries by default.

For instance, for KeePassXC, there are a number of graphical dependencies in the AppImage that just aren't available with Ubuntu Server.

I'm honestly not even sure what all of the dependencies are, since I tried to install them piecemeal without success. However, if you:

sudo apt install xterm

... then it will also come with all of the needed graphical libraries for (at least) KeePassXC (and probably others).

However, there are almost certainly AppImages that have other dependencies, such as a desktop environment (e.g. Gnome or KDE).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .