1

(disclaimer: I am… a certified noob)

I think I made a real mess while installing EndeavourOS (gonna call it EOS for short) and then trying to kind-of reinstall it… so I might need an advice of someone experienced. I’ll begin from the start (oh and yeah, I did post this on EOS forums, but... nobody seems to have solved my problem, that's why I went here)

I have an asus x550ik laptop with a hard drive of around 930 GB (if this is important, I also have one of these modern BIOS, which supports mouse and all that, I think they have another name of their own as well). Originally, I just had Windows 10 on it. I decided to pick a distro for myself to switch to (which was Fedora originally but not anymore), but I decided to keep Windows 10 just in case I would ever need it for a task that my new system would not be able to fulfill (I know not all Windows functions are perfectly recreated). So… I tried to make a new partition for Fedora (I encrypted it too), everything went alright.

after using it for some time, I decided that I want to switch to EOS instead, but I wasn’t sure whether to keep Fedora or not, and my 950 GB space allowed be to consider keeping it, so I decided I’ll keep it for now. I installed EOS, and it went fine too, but during the installation, there was a known bug (which the devs are already working on) - disk encryption is only available on the “install alongside” option (someone advised to try a manual partition too but it was full of options that I felt really unsure about). I have cleared up some space in the storage and made it unallocated beforehand because that was a problem I faced while installing Fedora. That’s why “install alongside” didn’t work for me and I went with another option, without disk encryption.

after some time, I felt like I wanted to reinstall my EOS, partially because I felt like I already got it full of unneded software, partially because I do want disk encryption after all, partially because I wanted to try out a different desktop environment. So I booted the live USB and I chose “install alongside” (since, again, only that option has disk encryption). My plan was: install EOS 2 alongside, then erase the EOS 1 through GParted and just keep using EOS 2. So that’s exactly what I did - I erased EOS 1 through GParted while still being in the live USB system. The erased partition started showing as “unallocated space” in GParted. I booted into the second EOS, and generally everything was (and still is) alright, it functions normally to this moment, but I have these problems now:

  1. my boot loader menu for some reason still has the old EOS versions, so now each kernel has 2 versions of booting, one of which never works ( due to me having cleared it’s partition, obviously)
  2. as shown on the screenshot below, when I open my file manager, on the left, for some reason, I see 2 systems named “endeavouros” and both of them have the same size (even though I vividly remember shrinking the EOS 1 to around 40-50 GB before erasing it, and the new one should be around 430 GB, but they both are 430 GB)

this confuses me and I am unsure what to do.

I asked someone in the community what’s the proper way to uninstall a system and they said “through GParted”, but that’s exactly what I did and… here we are.

so… what I’m asking for is this:

  1. I would like to be advised on how to PROPERLY erase all my current EOS, in such a way that they would not show up anywhere anymore, not in boot loader, not in file manager, etc.; only after that I wanna reinstall a clean EOS again, just to make sure to get rid of all the issues.
  2. I would also like to know which specific partitions of my hard drive I can erase (I only want to erase all EOS versions, not Fedora or Windows) to make it easier to tell which one is which, I would like to remind that only Windows and EOS 1 are non-encrypted, while Fedora and EOS 2 are encrypted (and again, EOS 1 was shrinked to around 40 or 50 GB and then erased through GParted)
  3. I would like to be explained, what are the small partitions from my hard drive. I know the big ones are Windows 10, Fedora and EOS, but the small ones (I highlighted them in red on the GParted screenshot) I have no idea about. What is each one of them? Should I remove any?
  4. apparently, I also have an error saying "Partition 9 does not start on physical sector boundary" (as seen on one of the screenshots below). I am hoping that this is not going to matter since I am planning to install a clean EOS all over again eventually?..

I attached some captioned screenshots in hopes that they would make sense to someone experienced in this, because to me they sure make little sense :')

please let me know if any additional info is needed. thanks a lot in advance to whoever is willing to try to help me out.

a scheenshot from GParted

a screenshot of my hard drive into from terminal

a screenshot of my file manager

2 Answers 2

0
  1. To completely erase the Endeavor OS install, you need to wipe the partition (like your friends recommended). You also need to remove the bootloader entry in grub. You can probably do this from your fedora install by editing the grub config in /etc/default/grub then running sudo update-grub. Here's another stack thread about grub: https://askubuntu.com/a/733433/1371704.

  2. I cant' tell you for certain which partitions you can delete. But I'd recommend booting all of the operating systems you want to keep and using df to view which partitions are mounting as the root filesystem (/). Those are partitions you'll want to keep.

  3. sda6 and sda9 are the only linux partitions that could be linux installs. sda1,2,and 3 are all Microsoft partitions that come with Windows. sda7 looks like your linux uEfi bootloader partition. (this is what gets read/written by grub). I'm not sure what sda5 is. Ext4 is a standard Linux partition, so you should be able to just mount this and see whats in there.

I know i wasn't able to answer everything but I hope this helps you get going in the right direction!

2
  • alright! Thanks a lot. May I ask, what exactly is "df", that's a terminal command, right? Just these two letters? and what exactly is "( / )"?.. (I'm sorry, I'm just... really inexperienced) also... is it safe to erase the partitions of uEfi boot loaders? As far as I remember, they were installed alongside with my distros, which I plan to reinstall anyway, so... it should be safe to remove those, right?.. or... Jan 9, 2023 at 20:48
  • given your level of experience, you might be better off installing VirtualBox on your windows machine and playing around with Linux in a VM on windows. This is the easiest way to try stuff out without putting important things like your bootloader and disk partitions at risk. Once you've played around like this and learned a bit more, then you can contemplate a bare-metal install. Just my opinion...
    – Brad
    Jan 9, 2023 at 21:11
0

update: (short summary) my problem was fixed by an advice of someone from EOS forums... then I had another problem, but thankfully that was fixed as well.

(more details) I asked someone from EOS forums whether it's safe to delete uEFI boot loader partitions (along with the system partitions) using GParted. They said that it is safe. They also helped me to determine which of my partitions were Windows-related (in my case it's /sda1-2-3-4) and which were not (/sda5-6-7-8-9). I deleted all non-Windows ones. Then I had another problem. For whatever reason, EOS installer did not create a new uEFI partition for my new EOS when I was installing it. I don't know why that was happening, my guess is that something went wrong when I first installed EOS on a separate partition and then also installed another EOS alongside the first one (on that same partition), then deleted the first one. I guess maybe the uEFI configuration got messed up or something... I don't know. In the end, some smart users from EOS forums were able to make sense of it, they advised me to manually create an EFI partition (with some important criteria - if you wonder which ones, check comments #97-121 of this thread) so that the EOS installer would recognize it and use it. It worked. Now I have a proper EOS install.

but still, thanks a lot to everyone here for taking the time and effort to help me!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .