0

I have recently assembled a PC with integrated Bluetooth. This is my motherboard: https://www.gigabyte.com/Motherboard/X570S-AORUS-ELITE-AX-rev-11/sp#sp

First I have installed Linux Arch that has recognized all without problem. In particular, the built-in bluetooth is what I wanted: I paired the Logitech MX vertical mouse, a keyboard, headphones and more. Everything works properly.

A couple of days ago I have installed Windows 11 in a partition, using Grub to dual boot. And here the problems arose. I paired all bluetooth devices and everything was ok. After windows 11 installation, gigabyte app center installed (because I didn't disable it from bios) and there have been various driver and firmware updates. At the and of all, I'm come back in Arch and mouse did not pair anymore. I have deleted association to try new pairing but bluedevil (I use KDE) does not detect mouse. Also bluetoothctl no longer detects the mouse. Windows 11 detects mouse, Arch no. So, I have taken an old Logitech mouse (Logitech M720 - I have two of the same and have tried them both with the same issue) and I have scan for the BT devices... Nothing, this mouse is no longer detected either. Even the huawei smartphone, while scanning sees the mouse. So I turned on the notebook, that has Linux arch and Windows 11 in dual boot.. As I imagined, both mouse are detected. From both Windows and Linux. At this point I have created a live usb with Ubuntu. Same result; Bluetooth scan detects all devices but Logitech mouses. This led me to rule out OS issues. Could something have changed in the BIOS? I don't know what to try anymore. In win 11 I have already disabled fast start.

I did a test with a bluetooth 5 usb dongle that I used before having the motherboard with integrated BT, and it detects all logitech mice without problems.

Recap:

  • On windows 11 Desktop: logitech mice - detected
  • On Arch Desktop: logitech mice - not detected
  • On Ubuntu live Desktop: logitech mice - not detected
  • On win 11 notebook: logitech mice - detected
  • On Arch notebook: logitech mice - detected

Here are some specifics:

  • OS: Arch Linux x86_64
  • Kernel: 6.1.3-arch1-1
  • DE: Plasma 5.26.5

1 Answer 1

0

As I was having a similar issue a few days ago, let me try to share my solution to my problem (maybe it would be relevant also for the OP):

Is the value of ControllerMode set to dual (or, set to le) in the main Bluez configuration file (on a standard Debian installation, it is /etc/bluetooth/main.conf) ?

1
  • In my main.conf, the ControllerMode is commented. What value do I have to set?
    – matiux
    Nov 28, 2023 at 15:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .