0

I'm running elementary 0.2 and whenever I open a .deb, it opens in Ubuntu Software Center. Is there any way to make it open in Synaptic instead? I just prefer Synaptic; quicker, easier to use.

  • How do you open it? Depending on your desktop environment you should be able to do something like click with right mouse button and select "open with" or "properties" and within those properties it should be possible to set the default application for that file type. – superuser0 Apr 20 '13 at 9:09
  • 1
    Last time I tried, synaptic didn't have the ability to install local .deb files. gdebi is another option if you don't like software center. – jordanm Apr 20 '13 at 15:02
  • maybe synaptic is a bit lighter than software center: but to have something simple and to the point - specifically addressing the deb installation issue - use gdebi. to install it, you may use the software center or synaptic, or the terminal: but to have something addressing specifically apt-links like the one i posted, use apturl which is really light (sudo apt-get install apturl) – user32012 Sep 26 '13 at 16:51
3

I am running Ubuntu 12.04 with the classic desktop, synaptic will not show up while right clicking a .deb package and will not show up in the list of other applications because it has no file type association with .deb files.

To add that association, edit /usr/share/applications/synaptic.desktop as root and add the line:

MimeType=application/x-deb;application/x-debian-package;

(You can also add %f after Exec=synaptic-pkexec on that line, but as synaptic does not seem to look at the argument provided that doesn't seem to help much)

After that run:

sudo update-desktop-database
killall gnome-panel
gnome-panel &

Now you should be able to select synaptic with right clicking. To make it my default application for .deb files run:

mimeopen -d path_to_my_deb_file

Then select the X) Other ... option and provide synaptic-pkexec as argument.

Only after all that does double clicking the .deb open synaptic (after prompting for credentials)

  • It wasn't appearing in the right click menu, but then I ran that last command and it worked. Thank you very much! – schtocker Apr 21 '13 at 11:03
1

I think you can do this through the file browser, Nautilus. I'm not familiar with Elementary but on my Ubuntu system I was able to launch Nautilus and then browse to a .deb file, right click on it, select "Properties" and then select the "Open With" tab and select an application to you want to open with, Synaptic.

Sorry in my Screenshots I don't have Synaptic installed but hopefully you get the idea.

     ss of nautilus

          ss of open with dialog

  • 1
    Are you sure you do not have synaptic installed? Because it will not show up in that list even if synaptic is installed. – Anthon Apr 20 '13 at 15:43
  • I didn't actually check if I had it or not on that system 8-). I'll go check now. – slm Apr 20 '13 at 15:48
  • Yeah it's there, /usr/bin/synaptic. So to add it you'd need to click the "Add" button and then manually put in the path to Synaptic. – slm Apr 20 '13 at 15:50
  • Elementary uses pantheon as it's file provider. I don't know if that has anything to do with it, but there was no 'Add' button. – schtocker Apr 21 '13 at 11:04
  • much ado about nothing: gdebi is the lightest app for debs – user32012 Sep 26 '13 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.