0

I'm having troubles with traceroute and tracepath. I'm doing some tests with my network trying to ping and trace Google DNS (8.8.8.8) The problem is that every time a run the command, it shows me a different result, I mean, sometimes trace is completed, and sometimes seems like traces it's stuck on the default Gateway. The same happens with tracepath. I'm connected via cable so, I don´t think it is a connectivity problem. A ping to 8.8.8.8 was running during the tests and it never stopped, so I'm not having problems with my ISP. Any advice?

enter image description here enter image description here

1 Answer 1

0

I can think of two things.

1 As you know paths are dynamic and therefore different hops may be involved in each issued traceroute, it means that different configuration is applied on each node. And some might reject the Linux traceroute messages as Linux traceroute uses UDP packets with ports higher than 33434 by default, thus if this type of packets are not permitted, then it fails. Apart from this, icmp packets can be also denied for security reason like DOS.

2 Because of this, you should run traceroute with the following parameter to "force" it to use only icmp messages:

traceroute 8.8.8.8 -I

Man page refers to this in the OPTIONS section:

-I, --icmp    Use ICMP ECHO for probes

For me with the help of "-I" option traceroute revealed an additional node.

To answer the other questions about traceroute messages are stucking on the gateway:
It can also be produced by security reason like rate limiting in both direction, because traceroute can cause storms by sending and receiving too much probes and replies. Rate limiting can lead to throttled or even dropped packets above the accepted rate.
So consider to use another parameter to lower simultaneously sent messages to only 1:

traceroute 8.8.8.8 -I -N 1

FYI UDP and ICMP is not connection oriented protocol, thus it is acceptable of not delivering some of these packets.

1
  • Thank you so much for your response. I tried with "tracerouter 8.8.8.8 -I" as you recomended and this works perfectly. Commented Jan 6, 2023 at 2:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .