As in the title. I can ping local networks, but there will be 10 packets in a row that would be lost, and the connection is very slow. There is no access to anything outside the network, including the default gateway, both when pinging IP and by domain name.

Using the step-by-step analysis here, I can't do anything after step 2. All other devices on the network work perfectly fine using that same ethernet cable.

I suppose the problem is two-fold: why is there packet loss on local network, and why can it not reach the external network? It's an old computer that I am just interacting with recently and seems to have a lot tampered with.

Ip route (eth0 is the one I am using for the web):

ip route
default via dev eth0 dev eth1  proto kernel  scope link  src dev eth0  proto kernel  scope link  src

Ip addr - the .97 is static and the .117 was set by dhcp

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:07:32:8f:ec:be brd ff:ff:ff:ff:ff:ff
    inet brd scope global eth0:0
    inet brd scope global secondary eth0
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:07:32:8f:ec:bf brd ff:ff:ff:ff:ff:ff
    inet brd scope global eth1

EDIT: ethtool

Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Half 1000baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

ethtool -S eth0

NIC statistics:
     tx_packets: 1847873
     rx_packets: 8265
     tx_errors: 0
     rx_errors: 0
     rx_missed: 0
     align_errors: 0
     tx_single_collisions: 0
     tx_multi_collisions: 0
     unicast: 343
     broadcast: 5915
     multicast: 2007
     tx_aborted: 0
     tx_underrun: 0
  • what if you reduce to number of IP addresses on eth0 to one? does it fix any of the issues? side note: that's amazing, what are the chances that your two NICs are 00:07:32:8f:ec:be and 00:07:32:8f:ec:bf! Jan 2 at 21:32
  • If I comment out the static IP , the dhcp auto-setup doesn't work at all, so there is no internet connection. Evidently some way the settings are set up rely on the .97 address
    – Cheetaiean
    Jan 2 at 21:45
  • what if you prevent the "DHCP auto-setup" instead of removing the static IP - or, remove one of the IP's manually Jan 2 at 22:01
  • Well then the situation remains the same. The only IP on eth0 is the static with the same limitations as described in my original post.
    – Cheetaiean
    Jan 2 at 22:06
  • 1
    Are you sure there's no IP conflict ? Did you checked your MTU ?
    – binarym
    Jan 2 at 23:10

1 Answer 1


There was a duplicate IP issue - in the IP Bind settings of my router the static IP I was setting my system to was registered to a different MAC address.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .