0

I am trying to start my virtual machine (RHEL 8) in my VMware but it displays this error

enter image description here

Previously I tried to unmount a newly added virtual HD which worked fine

But in lsblk -f it was still mounted

I thought restarting would work but then it started showing that screen from the image above

Can someone tell me why am I getting this error and what are the steps to fix this

5
  • Remove quiet rhgb from grub options, boot, take a picture, edit your question and post it here. Jan 1, 2023 at 13:59
  • what is quiet rhgb and how can I remove them Jan 1, 2023 at 14:37
  • 2
    Run the command in the error - journalctl -xb. It could be a bad entry in fstab, but you should see some details in the system log.
    – user103944
    Jan 1, 2023 at 16:33
  • journalctl may not necessarily contain any useful info if e.g. the root partition fails to get mounted. Jan 1, 2023 at 18:31
  • @user103944 you were right. It was a bad entry in fstab . I logged in as root in the emergency mode and removed the entry that caused the error. Now my system is working fine again. Thank You. Jan 2, 2023 at 8:06

1 Answer 1

1

I solved this error by removing the entry in fstab that I had made for the new Hard Disk Partition which was causing the error. I realised that I was trying to unmount a partition with the umount command which was actually mounted by making an entry in fstab

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .