0

I have tried installing both Emby and Plex (not ad the same time of course) on my Arch Linux system. I followed the relevant Arch Wiki pages for each. On both I am running into the same problem: They cannot see the contents of /run/media/$USER. I have two external drives mounted in that directory (initially mounted automatically using udisksctl, I tried adding an Fstab rule for one of the drives to see if that would make a difference).

I have added myself to groups plex and media, I have chowned the media directories. Nothing seems to make a difference. I have modified the systemd unit files as well, nothing changes.

Here is the ls of /run/media/jlcarveth

drwxrwxrwx  13 jlcarveth jlcarveth 4.0K Dec  9 10:45 JLC6TB
drwxrwxrwx   1 jlcarveth jlcarveth  12K Sep  4 20:48 Media

As I have mentioned this is on Arch linux, with updated packages running the 6.0.11 Linux kernel.

0

1 Answer 1

1

Looks like plex is installed as a systemd service on Arch. Certain settings for systemd services can cause them to use mount namespaces.

You may need to find the file plexmediaserver.service and edit it into your question.

But first consider moving where your drive is mounted. See the Linux FSH for more info. /run is a very strange place to mount anything.

Systemd may be specifically mounting something different at /run so consider using /mnt or /media

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .