0

Im using RHEL 8.7 I've added new HD nvme0n2 to my linux and created partititions successfully

the output of lsblk -f

NAME FSTYPE LABEL UUID MOUNTPOINT
nvme0n2
├─nvme0n2p1
│ xfs 5d966f3d-7aca-4f06-bf74-aa32d97aba76
└─nvme0n2p2
ext4 56f6e1d8-58f3-47c7-840b-c1eebc24c3f7

But when I try to mount that hard disk sudo mount /dev/nvme0n2 /mnt/newHardDrive/ , it says

mount: /mnt/newHardDrive: wrong fs type, bad option, bad superblock on /dev/nvme0n2, missing codepage or helper program, or other error.

when i tried checking in /var/log/messages, it shows:

kernel: XFS (nvme0n2): Invalid superblock magic number

I also tried replacing the superblock using the backup superblocks with the command sudo fsck -b 32768 /dev/nvme0n2

But then I get this error:

fsck from util-linux 2.32.1
e2fsck 1.45.6 (20-Mar-2020)
fsck.ext2: Bad magic number in super-block while trying to open /dev/nvme0n2
The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem. If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193
or
e2fsck -b 32768
Found a gpt partition table in /dev/nvme0n2

Please Help.

1 Answer 1

1

You can’t mount the device as a whole, you need to mount individual partitions:

sudo mount /dev/nvme0n2p1 /mnt/newHardDrive/
2
  • but I've read somewhere that we can mount a CD ROM and USB device Commented Dec 30, 2022 at 10:18
  • But this isn’t a CD-ROM or a USB device. Commented Dec 30, 2022 at 12:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .