I have a windows 7 VM in virtualbox and I'm used to connect the Internet though NAT. But after the last system upgrade, the Internet can't be reached in the VM.

I check the log at /var/log/pacman.log and find this:

[2013-04-16 16:03] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2013-04-16 16:03] [PACMAN] upgraded virtualbox-host-modules (4.2.10-4 -> 4.2.12-1)
[2013-04-16 16:03] [PACMAN] upgraded virtualbox (4.2.10-2 -> 4.2.12-1)
[2013-04-16 16:04] [PACMAN] upgraded virtualbox-guest-iso (4.2.10-1 -> 4.2.12-1)

I don't know its exact meaning but after browsing some wiki I tried to edit /etc/modules-load.d/virtualbox-modules.conf:


I also tried modprobe vboxdrv in CLI. All turned out to be of no use.


You might want to take a look at this wiki page in the Arch project's wiki:

I think you may need to run this command to get virtualbox up to date:

% pacman -Sy linux-headers && pacman -Su
  • Problem solved,thank you!I haven't read the wiki very carefully...
    – bigeast
    Apr 20 '13 at 0:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.