1

in short: My virtual machine named CONAN01 is not starting up in gnome-boxes, I receive/see different errors and do not know what the real issues behind them are:

Error 1:

When starting gnome-boxes from the Gnome desktop environment and clicking on my virtual machine CONAN01 to start it up, I receive a pop-up message with the option to open the error log and in this error log I can see the last lines, which state:

2022-06-15 09:39:22.707+0000: Domain id=1 is tainted: host-cpu
char device redirected to /dev/pts/0 (label charserial0)
2022-06-15T09:39:22.800582Z qemu-system-x86_64: warning: This family of AMD CPU doesn't support hyperthreading(2)
Please configure -smp options properly or try enabling topoext feature.
2022-06-15T10:30:56.757942Z qemu-system-x86_64: terminating on signal 15 from pid 3544 (/lib/systemd/systemd)

Error 2:

When using the terminal to start gnome-boxes and then using the mouse to click and run my virtual machine CONAN01, I receive following error:

gnome-boxes

error output at gnome-boxes startup:

(gnome-boxes:709111): Gtk-WARNING **: 22:02:27.216: GtkFlowBox with a model will ignore sort and filter functions

(gnome-boxes:709111): Gtk-WARNING **: 22:02:27.217: GtkListBox with a model will ignore sort and filter functions

(gnome-boxes:709111): GLib-GObject-WARNING **: 22:02:28.067: ../../../gobject/gsignal.c:2715: handler '2888' of instance '0x562fb55b44e0' is not blocked

error output at virtual machine CONAN01 startup:

(gnome-boxes:709111): Boxes-WARNING **: 22:02:32.045: machine.vala:605: Failed to start CONAN01: Unable to start domain: internal error: /usr/lib/qemu/qemu-bridge-helper --use-vnet --br=virbr0 --fd=31: failed to communicate with bridge helper: Transport endpoint is not connected
stderr=failed to create tun device: Operation not permitted

Error 3:

When executing the gnome-boxes – CLI checks by performing the necessary command, I receive following information:

gnome-boxes --checks

information output:

(gnome-boxes:717997): Boxes-WARNING **: 22:50:30.599: util-app.vala:376: Failed to execute child process ?restorecon? (No such file or directory)
• The CPU is capable of virtualization: yes
• The KVM module is loaded: yes
• Libvirt KVM guest available: yes
• Boxes storage pool available: no
    /root/.local/share/gnome-boxes/images is known to libvirt as GNOME Boxes’s storage pool but this directory does not exist
• The SELinux context is default: no

Report bugs to <http://gitlab.gnome.org/gnome/gnome-boxes/issues>.
Boxes home page: <https://wiki.gnome.org/Apps/Boxes>.

Despite changing the location of the storage pool by using the necessary commands, but the output showing the XML – configuration has not changed, virsh and gnome-boxes still think the old location is valid, my intend was to change “/home/myusername/.local/share/gnome-boxes/images”:

virsh pool-info gnome-boxes

Name:           gnome-boxes
UUID:           edb0bf37-df0f-4295-a3cf-0ced96970de0
State:          running
Persistent:     yes
Autostart:      yes
Capacity:       907,44 GiB
Allocation:     531,49 GiB
Available:      375,95 GiB

virsh pool-dumpxml gnome-boxes

<pool type='dir'>
  <name>gnome-boxes</name>
  <uuid>edb0bf37-df0f-4295-a3cf-0ced96970de0</uuid>
  <capacity unit='bytes'>974357393408</capacity>
  <allocation unit='bytes'>570679726080</allocation>
  <available unit='bytes'>403677667328</available>
  <source>
  </source>
  <target>
    <path>/root/.local/share/gnome-boxes/images</path>
    <permissions>
      <mode>0744</mode>
      <owner>0</owner>
      <group>0</group>
    </permissions>
  </target>
</pool>

sudo virsh pool-edit gnome-boxes

virsh pool-dumpxml gnome-boxes

<pool type='dir'>
  <name>gnome-boxes</name>
  <uuid>edb0bf37-df0f-4295-a3cf-0ced96970de0</uuid>
  <capacity unit='bytes'>974357393408</capacity>
  <allocation unit='bytes'>570679726080</allocation>
  <available unit='bytes'>403677667328</available>
  <source>
  </source>
  <target>
    <path>/root/.local/share/gnome-boxes/images</path>
    <permissions>
      <mode>0744</mode>
      <owner>0</owner>
      <group>0</group>
    </permissions>
  </target>
</pool>

1 Answer 1

0

The solution is to enable networking on the qemu-instance qemu:///session, because gnome-boxes creates the virtual machines on that instance, which is by default not able to have sophisticated networking access.

Either enabling it by giving qemu-bridge-helper a setuid bit:

sudo chmod 4755 /usr/lib/qemu/qemu-bridge-helper

or you can enable all executables in that folder:

sudo chmod 4755 /usr/lib/qemu/*

More sophisticated information can be found here and here:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .