After the bootloader, the last thing I see before systemd fills my screen, and then it goes blank, is the following:

Screen describing a media check of a USB filesystem, initially complaining about a lack of /sbin/sysctl

I am trying to install Fedora 37 to replace my current Windows 10. Mo matter if I choose UEFI or the one without it, the top message is always as in the picture:

[timestamp] dracut-pre-udev[618]: sh: line 1: /sbin/sysctl: no such file or directory`

The screenshot below is not of my machine, as my machine presents GRUB, but has the same choices (except for minor things like versions).

Fedora bootloader with "start" and "test" options

The messages about disk checks only come up if I choose "test this media & start fedora workstation KDE live 37".

In either case, once systemd has finished starting services, the screen goes blank, and doesn't proceed. What can I do to bring up the actual install screen?

  • Welcome to Unix & Linux. It is best to use text and code formatting for errors messages and similar instead of images. Images can not be searched, so people who are experiencing the same thing or people who know how to resolve this may not see your post. Dec 24, 2022 at 13:39

2 Answers 2


The /sbin/sysctl: no such file or directory error is probably a harmless minor bug.

Note that "Fedora workstation KDE live 37" is not just an installer: it is a "live" system, i.e. it will allow you to try Fedora with KDE desktop environment before you actually install it, and then run the installer from the KDE desktop.

Also, note that there is a third item in the boot menu, labeled Troubleshooting. Have you tried it?

Your hardware configuration, particularly the make and model of your GPU, would probably be important to know in this case. Please add this information to your question.


Use the third option. I literally solved it while I was reading the answer above. Use the troubleshooting option, then choose start fedora live in basic graphic mode and it will start. Some problem with Nvidia graphics I suppose

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .