0

I'm running LM 20.3 Cinnamon with Kernel 5.4.0-135-generic on a Thinkpad T470.

Connecting to bluetooth devices on this system generally has been everything from simple (e.g., smartphone) to frustrating (e.g., headset). In my latest attempt, I tried setting up this bluetooth keyboard from Lenovo. It now shows up in the BT device overview and connecting to it (either through the GUI or bluetoothctl) works effortlessly.

However, pairing fails consistently. Running bluetoothctl pair <address> after a while returns Failed to pair: org.bluez.Error.AuthenticationFailed, the same goes for the GUI. I suspect that some PIN code is required since hitting return prompts the fail message to appear faster. The keyboard's manual and online sources sometimes mention that typing PIN combinations such as 0000 or 1234 and hitting return is required to complete the pairing process. In this case neither worked.

This GitHub post suggests that the crux is indeed the respective bluetooth wizard's failure to show the required PIN code. Alas, following the suggested steps hasn't worked for me. Anybody with experiences regarding this particular product or similar errors with other devices? Any advice is highly appreciated.

1 Answer 1

1

YMMV

I discovered, trusted, connected to the trackpad. Then I selected to pair. Then in my terminal I opened bluetoothctl. This immediately updated my prompt to display

[TrackPoint Keyboard II]#

During the re-attempt at pairing, the bluetootctl displayed:

Agent registered
[CHG] Device F6:6A:66:47:8D:E4 Connected: no
[CHG] Device F6:6A:66:47:8D:E4 Connected: yes
[agent] Passkey: 227100

I entered that on the keyboard, hit Enter, and then everything updated as connected and paired. I can now use my trackpoint keyboard.

1
  • Thank you, this fixed it for me :)
    – iElectric
    Feb 18 at 5:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .