0

I have 2 wifi adapters on my odroid, wlan0 and wlan1, I connected to my wifi using nmcli with wlan1 successfully, but would like to be able to connect with wlan0 instead. However it seems no matter what I do (both removing the connection and deleting it from the network manager) nmcli will only allow the first adapter (wlan1) to connect to the connection. When I try the same command but replacing wlan1 with wlan0

nmcli d wifi connect <ssid> --ask ifname wlan0

it gives me this Error: Connection activation failed: (7) Secrets were required, but not provided.

but running the same command using wlan1 connects no issue. Does anyone know what I might be doing wrong?

Also these are 2 identical adapters, both confirmed working before, just cant 'swap' them on my wifi for some reason.

Extra info: Using odroid c4 with Armbian 22.11

1 Answer 1

0

For me the solution was to completely remove an already present instance of the connection first and then re-add it, restarting the NetworkManager in the process. For example:

nmcli connection show           # is your <ssid> present?
nmcli connection delete <ssid>  # then delete it
systemctl restart NetworkManager.service
nmcli device wifi connect <ssid> password <password>
nmcli connection reload
nmcli connection up <ssid>

This also solved the error message in the logfile CTRL-EVENT-ASSOC-REJECT ...status_code=16 that was assoicated with a wrong password (although the same password leading to this error works fine, after following the above listed steps).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .