4
┌──(root㉿kali)-[/opt]
└─# git clone https://github.com/tokyoneon/B2E.git 
┌──(root㉿kali)-[/opt]
└─# cd B2E/
┌──(root㉿kali)-[/opt/B2E]
└─# sudo apt install wine wine64 wine32 winbind winetricks    
┌──(root㉿kali)-[/opt/B2E]
└─# dpkg --add-architecture i386 && apt-get update && apt-get install wine32:i386
┌──(root㉿kali)-[/opt/B2E]
└─# wine 'Bat_To_Exe_Converter_(Installer).exe'                                  
wine: could not load kernel32.dll, status c0000135

There are not much solutions for this error. Any suggestions?

Not sure why I got -4 since I explained what I did and if you try to search on your own, you will also experience there is a really mess about this issue. Not clear solution.

Here is also my Linux version if it helps:

┌──(root㉿kali)-[~]
└─# wine --version
wine-7.0 (Debian 7.0~repack-10)
                                                                                                                              
┌──(root㉿kali)-[~]
└─# cat /etc/os-release                                   
PRETTY_NAME="Kali GNU/Linux Rolling"
NAME="Kali GNU/Linux"
VERSION="2022.4"
VERSION_ID="2022.4"
VERSION_CODENAME="kali-rolling"
ID=kali
ID_LIKE=debian

┌──(root㉿kali)-[~]
└─# uname -a                      
Linux kali 6.0.0-kali5-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.0.10-2kali1 (2022-12-06) x86_64 GNU/Linux

Same issue in Kali Linux, when I want to use "wine" to run "shellter.exe".

┌──(root㉿kali)-[/usr/share/windows-resources/shellter]
└─# wine shellter.exe 
wine: could not load kernel32.dll, status c0000135
3
  • Welcome to Unix. It is best to include relevant information such as the version of Linux and the version of the installed wine. Dec 22, 2022 at 0:59
  • Basically, this seems more like a bug than a problem to ask about, and you phrased it like a bug report. As it turned out, this wasn't the case, but StackExchange isn't for bug reports, and a question is at risk if it even smells like one to begin with.
    – TheLabCat
    Apr 10, 2023 at 19:54
  • 1
    As an aside, please don't use Kali as a general desktop OS. Even its own developers tell you that that's not what it's optimized for. Aug 5, 2023 at 11:23

1 Answer 1

19

I had the same issue and it was probably due to misconfiguration. It worked after I got rid of old ~/.wine folder. Run:

mv ~/.wine ~/.wine.old

or rm -r ~/.wine. Then run Wine again.

3
  • 1
    Thank you, this solved it for me.
    – TheLabCat
    Apr 10, 2023 at 19:54
  • 3
    This worked for me too! I was surprised, because I had just installed Wine, on a very new VM? But I think when I ran it the first time, without the 32-bit arch installed, that created configs that were no longer true once I finished setup.
    – Matchu
    Jun 9, 2023 at 17:38
  • If the answer helped people, can we get the question upvoted a bit too?
    – Anutrix
    Jan 5 at 6:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .