I'm not quite sure what's happening, but the title has the error message that pops up after running 'kex'. In the console it tells me to either try running 'kex kill' or 'kex start' neither of which work. I don't know much else other than that it's telling me the connection to the machine was refused and that it can't reach the Kex Server. And this pop up only appears after I try to use the 'kex' command from the WSL console. I've already tried uninstalling and resetting both Kali and WSL, neither worked. Any help would be greatly appreciated. Thanks!

This is all the pop up tells me. Text

1 Answer 1


I was experiencing this exact issue today. I saw a lot of suggestions to delete /tmp/.X11-unix, but when I tried that I found that it was mounted as read-only. This is what I did to resolve the issue:

kill kex
sudo su
mount -o remount rw /tmp/.X11-unix
cd ~
start kex

That resolved the issue for me (without having to actually delete the /tmp/.X11-unix directory).

  • 1
    This worked like a charm! Thanks, I had been trying to fix this for a while, I owe you one! Dec 18, 2022 at 3:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.