I have a 64 GB USB stick with four partitions:

  1. FAT for data transfer with Windows
  2. Linux bootable
  3. Encrypted Linux partition
  4. Linux partition

The booting from the bootable partition worked fine on most computers.  (Didn't work on an old MacBook with Intel CPU.)

I found an old laptop and tried to reinstall Linux via the bootable partition, but the F12 Menu could not find it (USB stick).

So I got into GRUB and typed:

(proc) (hd0) (hd0,msdos1)  (hd0,msdos2)  (hd0,msdos3)  (hd0,msdos4)  (hd1,gpt1) (hd1,gpt2) (hd1,gpt3) (hd1,gpt4)

I found out that the right partition is “(hd0,msdos2)”.

Partition hd0,msdos2: Filesystem type iso9660 - Label 'EOS_202209' - ...

and searched by pressing Tab for the .EFI file:

set root=(hd0,msdos2)/EFI/BOOT/BOOTx64.EFI

This file definitely exists and GRUB can see it, since it led me to it:

grub> chainloader +1

error: disk ‘(hd0,msdos2)/EFI/BOOT/BOOTx64.EFI’ not found.

What should I do?

1 Answer 1


In the PC world, there are currently two boot methods, the classic BIOS method, and the modern UEFI one. .EFI files are for the UEFI boot method only; an old laptop might only support the classic BIOS method. GRUB has separate architecture versions: i386-pc for classic BIOS boot, and x86_64-efi for UEFI.

The GRUB root variable should identify a partition, LVM logical volume or other filesystem container; not an individual file. chainloader +1 tells GRUB to read and execute the code in the first disk block off the partition identified by the root variable, and would be an appropriate command for chainloading the Windows bootloader for the BIOS boot method.

For UEFI, to run an .EFI file you would something like this:

set root=(hd0,msdos2)
chainloader /EFI/BOOT/BOOTx64.EFI

But that would most likely just manually repeat the part of the boot process that already brought you into GRUB in the first place.

If you want to boot Linux (or its installer), you don't want to run any more .EFI files once you have reached GRUB: you want to load a kernel file (typically with a command like linux vmlinuz-<version number>) and probably an initramfs/initrd file: its naming varies between distributions, but on Mint (a relative of Debian) the command would look like initrd initrd.img-<kernel version number>.

The filesystem label EOS_202209 suggests what you have is probably EndeavourOS, which is based on Arch, so I'm not sure why you're even mentioning Linux Mint.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .