5

I am running Debian testing with Firefox packages from unstable (as the esr version is too old for me). After Firefox was updated from 107.0.1-1 to 108 recently it won't start any more, saying:

 PCOMGlueLoad error for file /usr/lib/firefox/libnssutil3.so:
/usr/lib/firefox/libnssutil3.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM

I assume that Firefox 108 might depend on a package version which is outdated in testing or to put it more accurately, is newer on unstable. (Something similar occurred on RedHat apparently.)

Does anybody have an idea, what it could be and how to solve this?

3
  • 1
    @Quasímodo Sorry the title was missleading. I wanted to put to many informations in there I guess. Hope its clearer now: essentlly I running testing, but use the unstable sources for the firefox package.
    – user5950
    Dec 14, 2022 at 22:16
  • 2
  • @Quasímodo Thanks, I though it had something to do with my configuration using unstable packages on testing, therefor I didn't think of filing a bug etc. The solution in the bug comments works...
    – user5950
    Dec 14, 2022 at 23:26

3 Answers 3

2

This was a bug in firefox 108.0-1, fixed in firefox 108.0-2. Upgrade and Firefox will start.

1

If you download firefox-108.0.tar.bz2 from mozilla, and place it in its own directory to decompress, after decompressing you should find that the file libnssutil3.so is present in the newly created firefox directory, and that firefox can be run from that directory. You can arrange a script to run it from your $PATH just making sure that its name doesn't clash with the existing firefox-esr, if that older firefox is still there. The later firefox will create its own profile, so that you can run either firefox if you wish. On this machine one is named fox, and the other firefox.

1

I have the same problem, and I solved it like this:

sudo ln -s /usr/lib/x86_64-linux-gnu/*.so ./usr/lib/firefox/

Not the best solution, but it will work until this problem is solved by Debian.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .