I bought a new computer (Samsung NP900X4D) which came with Windows 8. I want to install linux (Mint 14) but the computer lacks any optical drives, and so the only option (I'm aware of) is using a bootable usb.

I created it using UNetbootin from the ISO I downloaded from the official web site and I changed the priority of the boot. The usb is not being recognized and so the windows loader starts up.

I tried to install mint from within windows which seemed ok, but once I rebooted I received an error when booting from mint. I tried to remove the installation and try again but now I can't even load windows and I get an error message with only the option to go back to the UEFI firmware settings.

I tried different usb sticks, on different ports but to no avail, it's always being unrecognized. I tried to use the stick on a different computer and it recognized the stick and loaded the installation, so it's not a problem with the stick.

Also, I'm pretty sure that the first time I tried the stick was recognized, and when I booted through it and selected to run mint it just got stuck, and then I rebooted and the stick is ignored ever since.

Any ideas?

  • Have you tried booting the USB stick on a different computer? – cjm Apr 17 '13 at 17:58
  • Oh, yes, sorry, I forgot to mention that. I did try it and the other computer recognized the stick. I'll edit my question with this. Thanks – Nitzan Tomer Apr 17 '13 at 18:00

There are a couple of steps that you should experiment with:

  • Disable Secure Boot in the UEFI interface

  • Check which mode you are booting in: UEFI, Compatibility or Legacy (you will likely only be able to, initially, use Compatibility or Legacy mode).

  • Make sure Fastboot is disabled in the UEFI interface

  • Ensure that the USB drive has highest priority in the boot order

  • If that machine has USB 2 and 3 drives, use the USB 2 port

All of these steps are necessary, in my experience, but may not be sufficient conditions to boot successfully from USB on the Samsung Series 9 machines.

Lastly, I am wary of bootable drives created with UNetbootin, I much prefer dd.

  • It worked! I'm not sure which part exactly.. it uses the UNetbootin version (though I made one using dd as well, thanks for that, learned a new command) and in the usb 3 port, but I disabled the secure boot and the fastboot and I disabled the harddrive in the boot devices, that did the trick. – Nitzan Tomer Apr 17 '13 at 18:54
  • @NitzanTomer Did you see your bootable USB flash drive in UEFI Boot Menu? For some reason I have only "Windows Boot Manager" there. – Martin Aug 16 '15 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.