• My Problem

    • I cannot access google in Firefox 107.0.1 64bit, the latest, when I connect my WiFi at home.
    • I can access youtube, and Unix stack exchange.
    • I cannot access zhihu.
    • I can access all of them with the same WiFi, on Windows, or with my phone's hotspot WiFi.
    • "not able to access" means it cannot load the webpage, instead of error; It just kept me waiting.
  • Basic Information

    • OS System : Fedora 37 WorkStation
    • Browser : Firefox latest
    • I have disabled the IPv6 in Firefox, not working.
    • I cannot ping google even I can access it normally when using the method written above like this: ping google.com
    • I changed my /etc/resolv.conf like this, still not working. I referenced this link, established a symbolic link to manually changed the nameserver (I don't really know if I have configure it correctly >_<)

options edns0 trust-ad
search .

and I've read this question but it's not a solution for me.

Since that I can access it normally by the hotspot on my phone, I guess it might be the IP??(but I'm not sure, and I know little in such an area)

Any suggestions would be appreciated !!

  • Are you using a tunnel? Do you have an interface with MTU less than 1500 (as visible in the first line for each interface with ip link)? Are you sure it wouldn't work better with IPv6 (eg: your phone might be using IPv6)?
    – A.B
    Dec 10, 2022 at 7:45
  • If you run ping -n google.com, does it successfully resolve Google's IP address? What if you try ping -4 -n google.com? If there seems to be DNS resolution problems, run traceroute -n -T -p 53 and likewise to all your configured DNS server addresses. This is a TCP traceroute specifically to port 53, and if it fails, the output might provide useful clues.
    – telcoM
    Dec 10, 2022 at 8:29
  • @A.B Yes I am using clash for linux on my computer. I tried running ip link show and the output is below:1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000 link/ether 68:3e:26:70:d3:bb brd ff:ff:ff:ff:ff:ff 5: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1400 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 500 link/none Dec 10, 2022 at 8:33
  • @A.B I'm sorry I don't know much about this command... So if there is indeed a problem here? Dec 10, 2022 at 8:35
  • @telcoM I tried running ping -n google.com and ping -4 -n google.com, but they both had a 100% loss rate. For traceroute, took 30 hops(max) and didn't reach, but others all reached the target IP within 30 hops. Does this show the problem? Will the machine check these nameservers one by one if the 1st one is not reachable? Dec 10, 2022 at 8:45

1 Answer 1


I've figured it out with another search on this topic. I just run sudo ifconfig wlp2s0 mtu 1492 and eveything back to work again. Still I don't know much about what's the matter in it, but luckily I can get access to all the websites normally.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .