I recently installed win-kex on my windows 11 machine. I was working perfectly on the first launch, but for whatever reason I began getting a fatal error. It didn't really provide much elaboration on that, so I checked to log file and found this:

(EE) XKB: Couldn't compile keymap
(EE) XKB: Failed to load keymap. Loading default keymap instead.
(EE) XKB: Couldn't compile keymap
XKB: Failed to compile keymap
Keyboard initialization failed. This could be a missing or incorrect setup of xkeyboard-config. 

I'm not sure what to do about this error. If anyone knows what's going on or has a recommendation, I'm all ears.

1 Answer 1


I had this only on W10. kex worked for ages and then started failing with exactly that error.

You can install WSL from the MS Store in addition to the version baked into the OS. This seemingly breaks kex.

Uninstalling the MS Store version of Windows Subsystem for Linux from the Programs menu (not Windows Features) fixed it for me. No further uninstalling / reinstalling of anything was necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.