1

I've recently bought a Lenovo IdeaPad 5 14ABA7 (Type 82SE) with a AMD Ryzen 5 5625U processor and Integrated AMD Radeon Graphics. The laptop comes without any OS and I installed Debian 11 on it (current kernel: 5.10.0-19-amd64). Unfortunately there is no specific documentation for this hardware.

The installation seemed to have been successfully with the exception of the WiFi adapter that was not working out of the box. Luckily I managed to solve the problem following this thread.

Unfortunately, I soon realised that there are a number of things that do not work:

  1. Suspension: if I push the suspend button, the system remain turned on (cursor on a black screen)
  2. Screen brightness: it seems the screen is always at its maximum brightness and cannot be adjusted (if a push the increase/decrease buttons the brightness does not change).
  3. Animation: I cannot see any animation. I suspect that the hardware graphic acceleration is not working
  4. Battery life: the battery life seems to me extremely short for a new laptop whose battery life is supposed to last up to 11 hours. I suspect there is something odd with the CPU governor or frequency.

I suspect that most of these problems are due to the fact that the hardware of Lenovo IdeaPad 5 is still not supported by the current Debian kernel. It is frustrating having a new laptop and not being able to run Linux on it. I'm not new to Linux but this time it seems that I have too many problems at once and my knowledge is very limited.

Please, if anybody can help with any of this issues, I would appreciate it very much. Thanks in advance for your time and kindness.

2 Answers 2

1

I've had issues with new hardware that isn't supported in Debian 11 standard, which comes with Kernel 5.10.0-18-amd64. I had to upgrade it to Kernel 6.0 (via backports), I've documented it all on the following answer. Some of it might not be relevant to you, so cherry pick what you want:

https://askubuntu.com/a/1442750/689452

(Although ordinarily, I would answer a question thoroughly for the sake of keeping the question/answer together, and keeping all notes on it in one place, I'm not going to copy it all to Unix SE site, as it is on AskUbuntu which is part of SE)

NOTE: For me, even after the above, I kept running in to an issue where my Wi-Fi adapter kept bugging out, so I've just installed the firmware-bookworm-DI-alpha1-amd64-DVD-1.iso, but as soon as I booted, there was an update for firmware-iwlwifi 20210818-1 which I updated to 20221109-2, and it started happening again, I've just downgraded to firmware-iwlwifi=20210818-1, let's see how that fares.

2
  • Hi Aubs, thank you very much for your answer and help. Before making such attempt, I would like to understand: 1. How can I go back to the stable Kernel version (5.10) if things go wrong with the backported one? 2. If I manage to install the backported Kernel (6.0) and things go well, what would happen when a new Kernel version will be available in the stable update channel (for example Kernel 5.11)? At that point should I remain with the new testing channel for all the packages and applications? This concern me a bit as I'm a regular user and never worked with testing versions of Linux.
    – Shevek
    Dec 4, 2022 at 18:20
  • 1. When you boot, do you get the grub menu? - You can select which Kernel to boot. I'd probably boot to a previous kernel, run sudo apt -t bullseye-backports remove linux-image-amd64 linux-headers-amd64, reboot. Any issues, reboot and select another kernel from the menu, then run the sudo update-grub to update the boot menu again. 2. Not entirely sure, I expect you can remove the later kernel as per (1), then run sudo apt list -a linux-image-amd64 linux-headers-amd64 to see which sources have a newer kernel, and update from there (remove the backport source if you no longer need it)
    – Aubs
    Dec 4, 2022 at 21:22
1

I have finally found a solution, thanks also to the suggestion of Aubs. I post that here in case it's of help for other people with a similar problem.

I have tried to update to Kernel 6.0 via backport as proposed by Aubs and it almost solved all the problems! This means: suspension, screen brightness, animation and battery life. The only issue with that is that the WiFi adapter (whose problem was initially solved as explain in my original post) stopped working. This is because the solution found there was for the Kernel 5.10 and not for Kernel 6.0.

Luckily, I finally found a solution also for the WiFi adapter in combination with the Kernel 6.0 and now everything seems to work as expected!

These are the steps I have followed:

# 1. Edit the source.list file (for example with vi) to include the bullseye-backports line:
vi /etc/apt/sources.list
deb http://deb.debian.org/debian bullseye-backports main

# 2. Update the packages:
apt update

# 3. Localise the backported kernel files:
apt list -a linux-image-amd64 linux-headers-amd64

# 4. Update the backported kernel files and reboot:
apt -t bullseye-backports install linux-image-amd64 linux-headers-amd64
reboot

# 5. Turn off your Security Boot in BIOS (if it's enable, in my case it wasn't)
# 6. Clone the rtl8852be driver by HRex39 using git (o simply download it from the URL in the following command):
git clone https://github.com/HRex39/rtl8852be.git -b dev

# 7. Enter the directory, compile the drivers and reboot:
cd rtl8852be
make -j8
make install
reboot

I could execute the steps above requiring an Internet connection through an old, pluggable USB-WiFi adapter. In any case, if you don't have one, the required files can be downloaded in a machine with Internet access and then moved to the Lenovo IdeaPad 5.

In my case the above procedure solved all the problems I was having with my Lenovo IdeaPad 5. Thank you very much to @Aubs for the suggestions without which I could have no solved the problems.

I think this solution will work also for Ubuntu and other Debian-based Linux distros.

3
  • Great, I'm glad you were able to get it sorted and listed the steps you used. I'm not sure, but you might want to check, if you do apt update, does it give you a huge list of packages that need updating? - If so, it will be taking them from the backport, and you might need to restrict backport to only provide the Linux kernel (see the nano /etc/apt/preferences part from my previous instructions).
    – Aubs
    Dec 15, 2022 at 23:55
  • Also, did you install from non-free ISO (see cdimage.debian.org/cdimage/unofficial/non-free/… - I used debian-live-11.5.0-amd64-cinnamon+nonfree.iso)? - It has lots of non-free drivers, (see packages.debian.org/bullseye/firmware-realtek I see RTL8852A listed) - If you're interested & have time, try running the live version if that doesn't work try the full install GUI, the first few steps of the install it'll prompt for network drivers before it actually does anything destructive, click NEXT & if it works you'll get prompted to select a wireless network.
    – Aubs
    Dec 16, 2022 at 0:10
  • Hi Aubs, thanks for your comment. I used the free ISO and for that reason I think I don't have the realtek drivers. Regarding the update, I think with the way I followed it only installed the Kernel (i.e. linux-image-amd64 linux-headers-amd64 reboot) from the backports and all the otherpackages are the "normal" ones for Debian 11. Thanks again for your help!
    – Shevek
    Dec 22, 2022 at 22:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .