1

I'm running an NFS server on Debian 11 (Bookworm) I'd installed the package nfs-kernel-server and have the following in my /etc/exports

/mnt/2TB        192.168.1.0/255.255.255.0(rw,anongid=1000,anonuid=1000,async,fsid=0,no_subtree_check,insecure,no_root_squash)
/mnt/2TB/weewx  192.168.1.182(insecure,rw,all_squash,anonuid=997,insecure,anongid=33,async)
/mnt/2TB/octoprint      192.168.1.0/255.255.255.0(anongid=1000,all_squash,insecure,anonuid=1000,anongid=1000,rw,async)
/mnt/2TB/media  192.168.1.0/255.255.255.0(anongid=996,no_subtree_check,insecure,no_root_squash,async,rw,anonuid=1001)

For some reason, some of my clients can access these NFS shares without any problem... specifically a Windows 10 PC, and Kodi running on a Google Chromecast.... yet other clients, specifically my raspberry pi devices, cannot access these NFS shares. They appear to mount, but I cannot access the directories at all, not even as root.

sudo showmount -a on the server shows the clients are in fact connected.

john@thindebian:~$ sudo showmount -a
All mount points on thindebian:
192.168.1.150:/mnt/2TB
192.168.1.3:/mnt/2TB
192.168.1.67:/mnt/2TB
192.168.1.67:/mnt/2TB/media
192.168.1.67:/mnt/2TB/octoprint
192.168.1.67:/mnt/2TB/weewx
192.168.1.76:/mnt/2TB

192.168.1.67 is my Google Chromecast 192.168.1.150 and 192.168.1.3 are my raspberry pis 192.168.1.76 is my windows 10 pc

the mount command on the raspberry pi shows the share is in fact mounted

192.168.1.2:/mnt/2TB on /mnt/2TB type nfs (rw,noatime,vers=3,rsize=1048576,wsize=1048576,namlen=255,soft,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.1.2,mountvers=3,mountport=43215,mountproto=tcp,local_lock=none,addr=192.168.1.2)

The file permissions for the shared directory are

drwsrwsrwx 1 nobody nogroup 2.6K Dec  2 00:04 2TB

Oddly enough.... this was all working fine a month ago and just stopped working on the raspberry pi devices.

I'm at a loss as to where to go from here. Perhaps I'm just missing something obvious, I don't know.... Can anyone offer any suggestions/assistance?

2
  • Dont know if it might point to the problem, but when it was working fine, i wasnt using the insecure parameter, but then one day nothing could connect...but adding that insecure parameter now at least lets the chromecast/kodi and windows pc connect. Commented Dec 2, 2022 at 22:45
  • When you mount on your Raspberry client what do you get by using sudo mount -vt nfs (-v for verbose mode)? Commented Dec 3, 2022 at 8:35

1 Answer 1

0

Check your /etc/nfs.conf file for udp=n.

Re-enabling it should allow your UDP based clients to connect.

Bookworm Bug - NFS UDP disabled by default

1
  • I don't have nor want any udp clients connecting. I'm specifying proto=tcp in the fstab file Commented Dec 31, 2023 at 5:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .