2

I'm running Pop!_OS 22.04 LTS (a flavor of Ubuntu), all updates available in the Pop Shop have been installed. Apps installed via flatpak appear to have a permissions issue.

For example--

  • Brave: can't import bookmarks
  • Calibre: Add books > select file gets message "calibre, version 6.9.0 ERROR: Cannot add books: You do not have permission to read any of the selected files."
  • Newsflash: Can't import file containing feeds, freezes when trying to import file
  • Element: Can't attach files
  • Zoom: Can't attach files in chat
  • KeePassXC: Can't add attachments, freezes when tried
  • Signal: Can't upload or download attachments, crashes after asking where to save the file.

I've installed Flatseal, but changing its settings has not helped (possibly because it too is a flatpak app). I also reinstalled flatpak. Running the apps from terminal doesn't help. Rebooting has not helped, nor has repairing flatpak.

Any suggestions would be much appreciated. Thank you!

10
  • What happens if you launch a Flatpak app from the CLI passing the --filesystem=home flag? E.g. flatpak run com.brave.Browser --filesystem=home.
    – telometto
    Commented Dec 2, 2022 at 10:39
  • Thanks. Same problem. I tried Signal so flatpak run org.signal.Signal --filesystem=home . Pressed the down arrow next to a photo to save it, was prompted to pick a location and then the app crashed. Commented Dec 2, 2022 at 12:50
  • Did you get any messages in the console?
    – telometto
    Commented Dec 2, 2022 at 14:46
  • Yep! Just put it on pastebin (please LMK if there's a better way to share messages or code that are longer than what we can post in the comments). Thanks! pastebin.com/f7DN06W4 Commented Dec 2, 2022 at 15:42
  • Re Calibre error. There is a section in the documentation faq that may be helpful: manual.calibre-ebook.com/… I am not sure it is wise to assume these are related problems and related to a system wide permissions problem. (Which seems unlikely in a fresh Pop install unless there were problems during installation.) I assume you have made sure your system is up to date by running sudo apt update followed by sudo apt upgrade (if you find anything to upgrade).
    – Steve
    Commented Dec 2, 2022 at 17:19

2 Answers 2

0

You should grab the Flatseal app from the Pop Shop. It will allow you to enable all of the Flatpak permission with a GUI.

0

Fixed the problem by deleting and re-installing all the Flatpak apps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .