1

I tried updating /opt/Citrix/ICAClient/config/wfclient.template (which is linked against /opt/Citrix/ICAClient/nls/en/wfclient.template) and removed the parameter that set fullscreen, but it didn't work.

Also did this in ~/.ICAClient/wfclient.ini

1 Answer 1

2
  1. Make sure the config is in the appropriate file and [section].
  2. Try specifying a desired resolution in addition to disabling fullscreen.

This works for me: in ${HOME}/.ICAClient/All_Regions.ini I have:

[Virtual Channels\Thinwire Graphics]
DesiredHRES=1280
DesiredVRES=960
ScreenPercent=*
UseFullScreen=*
TWIFullScreenMode=*
NoWindowManager=*
ResizeSession=

And Citrix starts up windowed, in a 1280x960 window. Adjust that resolution to taste, of course.

FYI, you can also temporarily get the Linux Citrix client to stop swallowing control keys by hitting ctrl-F2. After hitting ctrl-F2, your next control key sequence will be passed through to your local window manager, rather than being grabbed by Citrix and passed through to the remote end. So any local hotkeys to minimize Citrix, to switch to a different local app, to flip to a different local virtual desktop, etc, could be used to access the local machine while still leaving Citrix in full-screen mode.

4
  • Specifying a resolution works, but defeats the point of having the window be of dynamic size. The escape sequence to get shortcuts through is sometimes the only way to get out of fullscreen when Citrix glitches out and uses 100% of CPU all the time. It would be nice if Citrix just started in normal window mode instead of me having to do this everytime.
    – Ocean
    Aug 26, 2023 at 16:46
  • The specified resolution is only for start up -- it can be resized like any other window once running. If you want the initial resolution to be dynamically sized as a fraction of the total screen size, that's what the ScreenPercent parameter is about; I haven't used it personally, but it should work. You Aug 27, 2023 at 22:40
  • With that solution the session is stuck in that resolution for me. The window itself is flexible, but the session inside is fixed and will only have black if the window is bigger than the session inside.
    – Ocean
    Aug 29, 2023 at 20:09
  • this Ctrl+F2 trick is new for me. thanks. Oct 18, 2023 at 8:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .