0

When I launch a terminal from my Openbox menu my virtual terminal TTY jumps to the next CtrlAltF12 slot.

It seems that this problem appeared after I wanted some more than 7 TTYs and added some to /etc/inittab. I don't even know how to formulate a Google search. Every time I launch a terminal from OpenBox I need to press CtrlAltF11 - to return back from the terminal I've jumped to.

Here is my /etc/inittab: http://bpaste.net/show/91971/

/var/log/Xorg.0.log: http://bpaste.net/show/153905/

And after a year, as I understand nobody could help at any forum or #gentoo IRC (the question was opened 10 times at different time ..or so)

Yes, the system could live, though it's somehow annoying.

/update: The problem worsened from just jumping through TTY's to desktop not reacting on a mouse second time after the first successful launch of lxterminal/xfce-terminal ....etc.. etc... dozens of them (including xterm)


I'm adding my configs

cat /proc/cmdline
root=/dev/sda2

/etc/X11/xorg.conf:

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "VideoKey"              # <i>
        #Option     "WrappedFB"             # [<bool>]
        #Option     "GLXVBlank"             # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "PageFlip"              # [<bool>]
        #Option     "SwapLimit"             # <i>
    Identifier  "Card0"
    Driver      "nouveau"
    BusID       "PCI:2:0:0"
EndSection
1
1

May I answer my own nagging question, for I've got help from another forum. Then I did a little googling AND:

I had removed startx from ~/.bashrc - as non-login sript. Instead I wrote to the end of:

~/.bash_profile
...
startx

.bash_profile - is nogin-script only executed on login ONCE.

So, I guess, the effect was like this: NEXT TTY when I launched any terminal emulator every time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.