-1

I have installed vsftpd on my new Eee pc with Fedora 18:

sudo yum install vsftpd

How is it? :

systemctl is-active vsftpd.service

and got

failed

Then

systemctl status vsftpd.service

got

Failed to start Vsftpd demon
Unit vsftpd.service entered failed state

What is the best way to start repairing vsftpd?

  • 4
    Check /var/log for it's logs, /etc for it's configuration, maybe type dmesg to check if it isn't some bigger problem. – TNW Apr 16 '13 at 14:03
  • Please post the full output of systemctl status vsftpd.service, it should include enough logs to find out what is going on. – vonbrand Apr 16 '13 at 16:03
  • 1
    Fedora doesn't automatically start services once you install the package -- you need to enable and start them yourself. Did you do either of those? – jsbillings Mar 15 '14 at 1:18
0

By default vsftpd will listen on ipv6. Need to change it to ipv4 mode with the below modification to the file /etc/vsftpd/vsftpd.conf:

Existing entry:

listen=NO
listen_ipv6=YES

Change it to:

listen=YES
listen_ipv6=NO

Then start the vsftpd service:

systemctl start vsftpd.service
-1

I guess your vsftpd was never started. You may need to try to start it manually through /etc/init.d/vsftpd start and examine system logs for what happens.

-1

I've got the same error and I saw in the vsftpd status that the error was in /etc/vsftpd/vsftpd.conf

so, I just write (or uncomment):

listen_ipv6=NO

And then I could start vsftpd service with any problems

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.