0

I am running a Arch Linux 6.0.9 as a host for a Windows 11 virtual machine.

When I first installed the VM I had the option in Windows for 3840x2160 4k resolution with the default windows driver (I think it was windows basic display adapter) however after installing Spice guest tools and installing the included drivers, the windows display resolution now maxes out at 2560x1600. My video setting on the VM configuration page says QXL and I have tried VGA and Virtio, but they just give me various lower resolutions and none have the previously available 3840x2160. How do I make 3840x2160 available again in the windows guest machine?

I think it might have something to do with the Red Hat QXL controller display adapter but I do not know how to resolve the issue.

1 Answer 1

0

I have the same exact issue on ArcoLinux (as host system) with Windows 10 as VM guest and have installed spice-guest-tool-0.141.exe (2018 version), as it was the most recent available file I have found. The spice-guest-tool installation solved the problem of being finally able to obtain the copy-paste functionality between host and guest OSs, but caused the resolution issue...

This might be of some interest: https://www.reddit.com/r/VFIO/comments/aqk2pk/qemukvm_4k_resolutions_using_qxl_via_command_line/

I ran into something that I couldn't find an easier answer for and figured I'd post it here rather than find a specific distro wiki so I could give back something(tm) to everyone. ;) If anyone found a location explaining this topic more linearly feel free to refer to it for me so I learn to search better. I run a 3440x1440 monitor and run Gentoo with Windows VM's where I needed larger than the 2560x1600 max resolution of the standard QXL video driver. I googled (copyright curtailing verb form not proper noun...) multiple ways to do this for Ubuntu and libvirt XML but nothing for the command line. As I was about to post the question to reddit I found this:

https://bugzilla.redhat.com/show_bug.cgi?id=1273106

I can confirm Andrei Stepanov's command line works after I switch from qxl (which is also what's in the spice tools package) to the qxldod drivers in the the virtio 0.1.141 iso. I did have to switch to the drivers first then apply the video ram settings between reboot but that may be anectodal or transient to my scenerio using Windows 10. I believe guest support for Linux is far more straight forward with the same QEMU parameters. You may have to expand for larger resolutions. The math for it is elsewhere in the mainstream articles/posts.

-vga qxl -global qxl-vga.ram_size=134217728 -global qxl-vga.vram_size=134217728 -global qxl-vga.vgamem_mb=32

I had never known about the "-global" method of passing other parameters to QEMU. Something for me to learn about in the future more. Otherwise, there is enough on the internetz already to act on a libvirt solution.. I just haven't converted over, yet. Reading up on pvpanic does lend me to move towards something more advanced when I have time, though.

4
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 29, 2022 at 11:40
  • @AdminBee Your remark is correct, but since I'm far from being an expert concerning these topics, if I were to summarize what I haven't yet experimented, that would be a mere copy-paste of someone else's knowledge...
    – Alex
    Nov 30, 2022 at 11:12
  • @Alex as long as you clearly indicate that you are quoting someone else (as I did here by putting th quote in a quote block) and provide proper attribution, as you did by giving the link, there is no problem reproducing. On the contrary, that's precisely what we want so the answer will always work even if the link breaks in the future.
    – terdon
    Nov 30, 2022 at 13:02
  • Yes, I found the same, seems to fix copy and paste but breaks full resolution. I luckily had the machine already cloned which allowed me to jump back to a fresh install with Microsoft default display adapter intact. I found no way to reverse the process once Spice Guest Tools was installed. I attempted to roll back drivers and uninstall Spice Tools, but I could not get the resolution option fixed.
    – Orcam
    Nov 30, 2022 at 21:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .