0

Whenever I use sudo dnf to install a package on Fedora 36, this message always appears:

European Southern Observatory RPM repository fo 0.0  B/s |   0  B     00:06    
Errors during downloading metadata for repository 'esorepo':
  - Curl error (9): Access denied to remote resource for ftp://ftp.eso.org/pub/dfs/pipelines/repositories/stable/fedora/36/x86_64/repodata/repomd.xml [Server denied you to change to the given directory]
Error: Failed to download metadata for repo 'esorepo': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Ignoring repositories: esorepo

After, the terminal output seems normal and shows output relevant to the package I am about to install, but this previous message is annoying. Any suggestions?

1 Answer 1

3

According to its documentation, the esorepo repository is currently only supported for Fedora 33 to 35, CentOS 7 and Scientific Linux 7 (SL 7) for 64 bits architectures.

So you should disable or remove the esorepo repository from your package manager configuration, since it is going to be useless to you until support for Fedora 36 is added to the repository.

To disable the esorepo repository (so you can re-enable it later, if/when Fedora 36 support is added):

sudo dnf config-manager --disable esorepo

To remove the definition of the esorepo repository, look into your /etc/yum.repos.d/ directory, find the .repo file that defines the esorepo repository, and remove it. (If rpm -qf /etc/yum.repos.d/esorepo.repo indicates the repository file is installed by a particular RPM package, you might want to uninstall that RPM package instead, to achieve the same effect more cleanly.)

At your own risk, you might try editing the /etc/yum.repos.d/esorepo.repo file to refer to the packages of Fedora 35 instead, as the ftp.eso.org server simply does not yet have a directory for Fedora 36.

There are two lines in the esorepo.repo file you would need to change:

baseurl=ftp://ftp.eso.org/pub/dfs/pipelines/repositories/stable/fedora/$releasever/$basearch

and

gpgkey=ftp://ftp.eso.org/pub/dfs/pipelines/repositories/stable/fedora/$releasever/$basearch/eso-pubkey.asc

On both of those lines, you would need to replace the $releasever with 35. This will cause the package manager to look into esorepo's Fedora 35 directory, instead of trying to access the non-existent directory for Fedora 36.

You must then be careful to only install any packages from esorepo into the fedora-toolbox-35 container only (like you mentioned in the comments), not into the Fedora 36 host OS.

2
  • I see, but I actually need esorepo for my research. I have installed and been using it in a toolbox toolbox enter fedora-toolbox-35
    – Dila
    Commented Nov 22, 2022 at 6:21
  • The fact that you actually use the esorepo in a toolbox container based on Fedora 35 is important information. You might want to edit your question to add that fact in, in case someone else can suggest a better way for that specific situation; otherwise, see my edit above.
    – telcoM
    Commented Nov 22, 2022 at 9:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .