0

I've trying to compile Claws-mail but got error:

perl_plugin.c:54:10: fatal error: EXTERN.h: No such file or directory
   54 | #include <EXTERN.h>

I've installed perl-core perl-devel was already installed.

I can run perl -v

# perl -v | grep built
This is perl 5, version 36, subversion 0 (v5.36.0) built for x86_64-linux-thread-multi

but the problem is that there is no /usr/lib/perl5 directory. I've found that the file is in /usr/lib64/perl/CORE/ but I have no idea how the compile the application, the author of Claws-mail said that something is wrong with my system and he can't help me.

I've tried to add

export INCLUDE="/usr/lib64/perl/CORE/"

but the error remains. I'm not able to compile the application.

What's weird is that list of package files shows that the path should be /usr/lib/ not /usr/lib64.

My system was upgraded from I think Fedora 35.

2
  • I’m assuming you have a specific reason not to use the Fedora claws-mail package ;-). Nov 21, 2022 at 12:10
  • 1
    @StephenKitt I want to test the latest git version that fixed the issue I was having.
    – jcubic
    Nov 21, 2022 at 14:54

1 Answer 1

1

You need to install perl-ExtUtils-Embed. See the Fedora claws-mail.spec for reference (it’s perl(ExtUtils::Embed) there).

You also need to re-run configure after installing new packages.

(Note that your list of package files comes from the i686 package; you need to look at the x86_64 package instead.)

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .