0

I'm using OpenCore on an iMac15,5, with the OpenLinuxBoot.efi driver to directly boot Fedora 37 with kernel 6.0.8, bypassing GRUB.

Normally, in my GRUB config, fedora would add some default boot arguments rhgb quiet to enable graphical boot. Can I pass those arguments to linux via my OpenCore configuration? Where would I enter those boot arguments?

1 Answer 1

0

Following the guide at https://dortania.github.io/docs/latest/Configuration.html#additional-information, I mounted my boot partition, then edited the file in /boot/loaders/entries/*.conf which corresponded to my kernel version, and added rhgb quiet at the end of the line starting with options. The file looked like this in the end:

title Fedora 37
version 6.0.8-300.fc37.x86_64
linux /vmlinuz-6.0.8-300.fc37.x86_64
initrd /initramfs-6.0.8-300.fc37.x86_64.img
options root=UUID=11111111-cccc-22223333-444455556666 ro rootflags=subvol=root rhgb quiet
grub_users $grub_users
grub_arg --unrestricted
grub_class fedora

When I restarted, I got my fancy graphical boot screen!

I also tried mounting my EFI partition at /run/media/bennyp/EFI and editing /run/media/bennyp/EFI/EFI/OC/config.plist, and then changing UEFI>Drivers>Arguments for OpenLinuxBoot.efi to autoopts="root=UUID=11111111-cccc-22223333-444455556666 ro rootflags=subvol=root rhgb quiet". This did not appear to work when I reverted the changes to /boot/loader/entries/*.conf, So this remains a partial solution for now - I'll have to update my entries file for each new kernel version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.