1

I am trying to delete some of my post from http://ix.io

I have a file test.txt and ~/.netrc with this content:

$ cat test.txt
Hello World!
$ cat ~/.netrc
machine my_ip_addr login my_username password my_passwd

I post it with:

$ curl --netrc -F 'f:1=@./test.txt' ix.io
http://ix.io/3LCu
# This link actually works

Now lets delete the post with this:

$ curl -n -X DELETE ix.io/3LCu
user required
# This does not work.

And the link still works! I want to delete it, what am I doing wrong?

3
  • The example of a ~/.netrc file found in the curl(1) manual uses three separate lines (one for machine, one for login, and one for password). Following that pattern, does it make it work? Also, is my_id_addr in that file actually ix.io (it should be the address of the server you are connecting to).
    – Kusalananda
    Commented Nov 18, 2022 at 8:49
  • Nope, still didn't work :(
    – manungsa
    Commented Nov 18, 2022 at 12:48
  • see if it works when specifying the path using --netrc-file /home/user/.netrc
    – SelfTaught
    Commented Nov 19, 2022 at 1:11

1 Answer 1

0

Solved. I just know that my_username should be replaced by my linux login username, and my_password should be replaced by my linux login password. Previously I make some different username and password.
So here's the content of the file:

$ cat ~/.netrc 
machine ix.io
login my_linux_login_name
password my_linux_login_password

And now, the CURL deletion request worked.
Please correct me if I'm wrong.

EDIT: Now I think that it has to do with a comment, so previously the password format is something like password #passwd, maybe the #passwd is considered a comment because of the pound sign, so I get some error message like this:

$ curl -n [request]
cant add user username: no token

After changing the password so it doesn't contain pound sign, now the curl request worked. My bad :/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .