6

Long story short, I have a Ubuntu 12.04 64-Bit Server setup as a virtual machine with VirtualBox (4.1.18). I migrated the guest machine from an AMD chipset (a gaming machine) to an Intel Xeon (server hardware with dual processor support) thinking that there wouldn't be any issues. Once I got the guest machine setup on the server, I started the guest machine only to find that it hangs at "Loading Initial Ramdisk".

I mounted the Ubuntu 12.04 64-Bit setup ISO to see if I could get in to see any logs, but get "Kernel requires x86-64 CPU, but only detects i686 CPU" when trying to boot off the ISO. Keep in mind that host OS on both source and destination machines are also Ubuntu 12.04 Server 64-Bit. This lead me to look into how the guest OS sees the CPU information within the virtual machine. I found that the CPU information looks exactly the same on the host as it does on the guest on the source machine.

Source CPU Info:

Processor - AMD Phenom™ II X4
Model - 925
OPN Tray - HDX925WFK4DGI
OPN PIB - HDX925WFGIBOX
Operating Mode 32 Bit - Yes
Operating Mode 64 Bit - Yes
Revision - C2
Base Speed (MHz) - 2800
Boost Speed (MHz)
Voltages - 0.850-1.425V 
Wattage - 95 W
AMD Virtualization Technology - Yes
L1 Cache Size (KB) - 128
L1 Cache Count - 4
L2 Cache Size (KB) - 512
L2 Cache Count - 4
L3 Cache Size (KB) - 6144
CMOS - 45nm SOI
Socket - AM3
AMD Business Class - No
Black Edition - No

Destination CPU Info:

3 Ghz Xeon - SL7ZF
Number of Cores - 1
Clock Speed - 3 GHz
L2 Cache - 2 MB
FSB Speed - 800 MHz
FSB Parity - Yes 
Instruction Set - 64-bit
Embedded Options Available - No
Lithography - 90 nm
Max TDP - 110 W
VID Voltage Range - 1.2875V-1.3875V
Physical Address Extensions - 32-bit
ECC Memory Supported - No
Processing Die Size - 135 mm2
Number of Processing Die Transistors - 169 million
Sockets Supported - PPGA604
Intel® Hyper-Threading Technology - No
Intel® Virtualization Technology (VT-x) - No
Intel® Trusted Execution Technology - No
Intel® 64 - Yes 
Idle States - Yes 

I found a similar question, but wasn't sure if this is applies to my situation. The destination cpu show to support 64-Bit instructions. On the other hand, I've also read that Intel's 64-Bit is not true 64-Bit.

Am I stuck rebuilding my guest VM from scratch?

  • 2
    I think there should be no problem in running this VM on the new processor. Could you please boot again the guest without the "quiet" kernel option in order to have more details on what the problem is? (I might be wrong, but I assume that a linux kernel is loaded, while the problem may be earlier.) – eppesuig Apr 15 '13 at 15:12
  • 1
    @eppesuig I have to admit, I've been trying to figure out GRUB on the fly but I am having trouble. I think it might be worth mentioning that the volume is encrypted through LVM with LUKS. With that said, I believe initrd is being used. I'm still learning. – Chad Harrison Apr 19 '13 at 14:50
2

Your problem may not be with the new processor but your vm's settings. The first machine with the amd processor has visualization support built into the processor and the second does not. There is an option in the settings for the virtual machine under system > Acceleration > ... for hardware acceleration which the Intel machine does not have.

enter image description here

"Intel® Virtualization Technology (VT-x) - No"
  • 1
    Unfortunately, this did not help :( – Chad Harrison Apr 19 '13 at 14:46
  • 2
    maybe un-checking the option "PAE/NX" under the processor tab could help. – Joe May 1 '13 at 5:30
2

I was stuck on "Loading initial RAM Disk" too. Actually in my case guest system was Debian 64-bit. And the problem was solved when I specified exactly the type of the OS in the General > Basic > Version.enter image description here

  • 1
    Upwoting answer - only this actually helped. – sandric Sep 29 '18 at 23:19
0

I set the paravirtualization setting from "none" to "default", and then it worked again.

  • 2
    This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – perror Jul 30 at 12:51
  • @perror This setting for the virtual machine in the Virtual box VM settings one of the reasons the virtual machine may hang during kernel boot at "Loading Initial Ramdisk". If this helps OP or others with the virtual machine moving between 64 bit hosts I can't tell for sure but it's worth a shot. – user643011 Jul 30 at 18:57
  • @GAD3R: I have to say I am suprised, I once don't put in the effort to style the reply, provide screenshots and so on. And I immediately get a delete vote and 3 recommended deletes for low quality post. It's almost comical. No the post is a bit light, and the question is quite old, but the answer addresses the question and should not be deleted. – user643011 Jul 30 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.