I have a problem. After an update, my USB drives are not mounted automatically and I'm unable to mount them manually...

The output of my fdisk -l command is:

Disk /dev/sdb: 15.8 GB, 15762194432 bytes
2 heads, 63 sectors/track, 244329 cylinders
Units = cylinders of 126 * 512 = 64512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x018d6a09

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1      244330    15392736    b  W95 FAT32

I tried with

mount -t nfs /mnt/usb /dev/sdb1

but it dowsn't work. Any ideas?


You need to use mount command as below :

sudo mount /dev/sdb1 /mnt/

it will check and automatically detect and mount filesystem i.e vfat

  • It says me mount: only root can do that – sharkbait Apr 15 '13 at 14:39
  • 1
    Do it as root, then. – Renan Apr 15 '13 at 14:52
  • I did it. But I'm logged in with another user... – sharkbait Apr 16 '13 at 8:50
  • This is a solution. But one question: if I'm logged in with another user, I have to manually copy from terminal files in the usb device. I would copy them with drag and drop, not with the cp command – sharkbait Apr 16 '13 at 9:01

If mount is an issue and your system uses udisks try:

udisks --mount /dev/device
udisks --mount /dev/sdc1

And / or have a look at e.g.

ls -l /dev/disk/by-label/

And mount by e.g.:

udisks --mount /dev/disk/by-label/MyUSBDevice


  • Cannot find device with major:minor 8:17: Launch helper exited with unknown return code 1 – sharkbait Apr 16 '13 at 8:55
  • For USB devices you would most likely use udisks as if correctly set up it does not require mount privileges etc. (You won't have to sudo it). Try running udisks --monitor and re-plug device. It should be detected and mounted. Check system logs etc. and debug from there. – Runium Apr 16 '13 at 9:33
  • Nothing... the monitor didn't see my usb device.... – sharkbait Apr 16 '13 at 11:26
  • udevadm monitor and check log files; e.g. /var/log/syslog – Runium Apr 16 '13 at 12:08
  • With this command I see something when I plug in the usb device. But I don't have a syslog file.. – sharkbait Apr 16 '13 at 14:05

create a directory on for example:


Then run the command:

$ mount -t vfat /dev/sdb1 /home/YourUserName/Desktop/MyUsb

-t vfat = for msdos (fat-fat16-fat32 etc.)
-t ntfs = for ntfs
-t ext2 = for ext2
-t ext3 = for ext3
-t ext4 = for ext4

On linux systems and many Unix systems, entries in the file /etc/fstab govern whether and where a device is mounted at startup. Use the command man fstab for details about fstab entries. Here are some examples:

/dev/sdf1  /sf1  fuseblk user,rw,nosuid,nodev,noauto 0 0
/dev/sdg3  /sg3  ext2    user,auto,nosuid,nodev      0 0
UUID=994228d4-etc-7f1d7d0 /usr   ext4 defaults       0 2

Items with a user keyword in them allow the user to mount or umount the corresponding device without needing to use sudo or su. Items with auto mount automatically on system startup (and if not present may cause startup problems). Items with rw are mounted read-write.

When fstab entries specify both a device and a mount point the mount command only needs to give one of them. For example, given the above entries, /dev/sdf1 can be mounted by the user at /sf1 by either of the following commands:

mount /sf1
mount /dev/sdf1

On linux systems or Unix systems with /proc you can see a list of partitions, mounted or not, via

cat /proc/partitions

If you know the UUID's of partitions on your USB drive, you can use the UUID instead of the device name in its fstab entry. On some linux systems, use

ls -l /dev/disk/by-uuid/

to see the correspondence of UUID's and devices.


I am using centOS 7 with the Mate desktop. I ran into a the problem of not being able to mount a USB disk. Short answer. Make sure that you have the desired users that you want to be able to mount USB devises to the disk group.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.