0

If I'm not wrong, Lynx will save the cookies from a session on a file, the default is ~/.lynx_cookies. But, when I accept cookies in Lynx session with Always or Yes when prompted, the cookies doesn't saved!

Lynx man page says:

-cookie_file=FILENAME
specifies a file to use to read cookies. If none is specified, the default value is ~/.lynx_cookies for most systems, but ~/cookies for MS-DOS. -cookie_save_file=FILENAME
specifies a file to use to store cookies. If none is specified, the value given by -cookie_file is used.

But I don't have such file on my home directory.

What should I do to enable cookies on Lynx?

EDIT:
Thanks @stoney! It works!
What I have done:

$ cp /etc/lynx.cfg $HOME
$ export LYNX_CFG=$HOME/lynx.cfg

Add/edit this line on $HOME/lynx.cfg

SET_COOKIES:TRUE
PERSISTENT_COOKIES:TRUE
COOKIE_FILE:~/.lynx_cookies
COOKIE_SAVE_FILE:~/.lynx_cookies

Restart your terminal (or just source your .bashrc). Then, restart lynx. Done!

1
  • I removed "[SOLVED]" from the title. It is evident from the fact that you have accepted an answer that the issue is resolved.
    – Kusalananda
    Commented Nov 14, 2022 at 14:08

1 Answer 1

3

Look for the config-directive PERSISTENT_COOKIES, this is what you're searching for. It's configured in lynx.cfg, usually in /etc/lynx/. You can use environment-variable LYNX_CFG to switch to another config.

This setting is more or less the opposite of "Discard Cookies at session-end" in desktop-browsers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .