3

Obligatory searched the internet etc.

My Debian 11 system cannot install steam via APT. Many of it's dependencies rely on libc6:i386 but APT complains that it is not installable. When I attempt to install it directly via APT, it complains that hunspell-fr (a dependency package) is uninstallable. However the default version of hunspell-fr, hunspell-fr-classical, which the dependency package depends on, is already installed on my system.

I've enabled the i386 architecture via dpkg, updated APT's index files and upgraded.I've also tried explicitly enabling i386 packages by passing the [ arch=amd64,i386 ] option in /etc/apt/sources.list. I've cleaned the index file cache and auto-removed orphaned dependencies. All sections are enabled including, contrib and non-free, for the bullseye, bullseye-security and bullseye-updates distributions.

nohatsatthetable@debian:~$ uname -a
Linux debian 5.10.0-19-amd64 #1 SMP Debian 5.10.149-2 (2022-10-21) x86_64 GNU/Linux

All help is appreciated!

Terminal output when attempting to install steam:

nohatsatthetable@debian:~$ sudo apt-get --simulate install steam
[sudo] password for nohatsatthetable: 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libatomic1:i386 : Depends: libc6:i386 (>= 2.3.6-6~) but it is not installable
 libbsd0:i386 : Depends: libc6:i386 (>= 2.25) but it is not installable
 libdrm-amdgpu1:i386 : Depends: libc6:i386 (>= 2.28) but it is not installable
 libdrm-intel1:i386 : Depends: libc6:i386 (>= 2.17) but it is not installable
 libdrm-nouveau2:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libdrm-radeon1:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libdrm2:i386 : Depends: libc6:i386 (>= 2.17) but it is not installable
 libedit2:i386 : Depends: libc6:i386 (>= 2.28) but it is not installable
 libelf1:i386 : Depends: libc6:i386 (>= 2.28) but it is not installable
 libexpat1:i386 : Depends: libc6:i386 (>= 2.25) but it is not installable
 libffi7:i386 : Depends: libc6:i386 (>= 2.7) but it is not installable
 libgcc-s1:i386 : Depends: libc6:i386 (>= 2.2.4) but it is not installable
 libgl1:i386 : Depends: libc6:i386 (>= 2.1.3) but it is not installable
               Depends: libglx0:i386 (= 1.3.2-1) but it is not installable
 libgl1-mesa-dri:i386 : Depends: libc6:i386 (>= 2.29) but it is not installable
 libglapi-mesa:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libglvnd0:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libgpg-error0:i386 : Depends: libc6:i386 (>= 2.28) but it is not installable
 libllvm11:i386 : Depends: libc6:i386 (>= 2.29) but it is not installable
 libmd0:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libpciaccess0:i386 : Depends: libc6:i386 (>= 2.7) but it is not installable
 libsensors5:i386 : Depends: libc6:i386 (>= 2.29) but it is not installable
 libstdc++6:i386 : Depends: libc6:i386 (>= 2.23) but it is not installable
 libtinfo6:i386 : Depends: libc6:i386 (>= 2.16) but it is not installable
 libudev1:i386 : Depends: libc6:i386 (>= 2.30) but it is not installable
 libvulkan1:i386 : Depends: libc6:i386 (>= 2.29) but it is not installable
                   Recommends: mesa-vulkan-drivers:i386 but it is not installable or
                               vulkan-icd:i386
 libx11-6:i386 : Depends: libc6:i386 (>= 2.28) but it is not installable
 libxau6:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libxcb-dri3-0:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libxcb1:i386 : Depends: libc6:i386 (>= 2.28) but it is not installable
 libxdmcp6:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libxext6:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libxinerama1:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 libz3-4:i386 : Depends: libc6:i386 (>= 2.30) but it is not installable
 libzstd1:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
 steam:i386 : Depends: libc6:i386 (>= 2.15) but it is not installable
              Recommends: libasound2-plugins:i386 but it is not installable
              Recommends: libxss1:i386 but it is not installable
              Recommends: mesa-vulkan-drivers:i386 but it is not installable
              Recommends: xdg-desktop-portal:i386
              Recommends: xdg-desktop-portal-gtk:i386 or
                          xdg-desktop-portal-backend:i386
              Recommends: xterm:i386 or
                          x-terminal-emulator:i386
              Recommends: zenity:i386
 zlib1g:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
E: Unable to correct problems, you have held broken packages.

Terminal output when attempting to install libc6:i386

nohatsatthetable@debian:~$ sudo apt-get --simulate install libc6:i386
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 hunspell-fr : Depends: hunspell-fr-classical but it is not going to be installed or
                        hunspell-fr-revised but it is not going to be installed or
                        hunspell-fr-comprehensive but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Output of dpkg --print-foreign-architectures

nohatsatthetable@debian:~$ dpkg --print-foreign-architectures
i386
6
  • steam and libc6:i386 don’t depend on hunspell-fr so that error is rather surprising. Could you edit your question to show the full output of apt install steam and apt install libc6:i386? Nov 13, 2022 at 19:36
  • @StephenKitt Thanks, I've added the output of apt-get to my post. Considering the purpose of huspell-fr*, I thought it unusual that libc6:i386 should depend upon it, and as you say - it doesn't. What's even stranger is that hunspell-fr-classical is actually installed on my system. Nov 15, 2022 at 13:28
  • Kind of a silly question, and you seem to know what you're doing, but after looking into the Debian package list hunspell-fr is a French dictionary. Are you French? As @Stephen-Kitt says, it isn't required by steam and libc6:i386 doesn't exist. Have you tried apt-get update && apt-get upgrade && apt-get dist upgrade? Nov 15, 2022 at 13:35
  • The question says “I've enabled the i386 architecture via dpkg, updated APT's index files and upgraded.” Nov 15, 2022 at 13:41
  • 1
    You're right, I didn't read that part correctly. I still cannot find a single package that is called that exactly on the Debian list, but my advice above is taken from this askubuntu thread. I am unsure on how to change mirrors from the cli, but that is the top answer. Other answers indicate doing what you've already tried. Perhaps try this suggestion: "I solved the problem by downloading libc6:i386.deb from packages.ubuntu.com/bionic/libc6 and executing 'sudo dpkg --force-overwrite -i xxx1.deb'" Nov 15, 2022 at 13:48

1 Answer 1

0

Removing hunspell-fr solves one problem; however, there's a deeper problem: steam wants to install libc6:amd64 and libc6:i386. As far as I can tell, something is broken is debian.

   The following packages have unmet dependencies:
    libc6 : Breaks: libc6:i386 (!= 2.36-7) but 2.31-13+deb11u5 is to be  installed
 libc6:i386 : Breaks: libc6 (!= 2.31-13+deb11u5) but 2.36-7 is to be installed
E: Unable to correct problems, you have held broken packages.
1
  • 1
    You are trying to install a version of steam that's intended for some distribution that uses libc6 version 2.36, and Debian 11 uses version 2.31. This is just the sort of dependency conflict that happens when you add repositories intended for other distributions than the one you're actually using. My Debian 11 with Steam installed gets it from repository deb [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam and the package to install is steam-launcher, not steam which is "a transitional package that can be safely removed once steam-launcher is installed".
    – telcoM
    Jan 14, 2023 at 16:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .