0

I tried to install Debian11 and other Debian based distros on my System76 Galago Pro device and all failed to boot except the in house developed PopOs!. Plot twist the same installation works on a System 76 Darter Pro device.

All the other debian distros with UEFI/grub install show the following message only after the second restart. Could anyone explain me why after the second restart and why this whole thing happening? Edit: After the first login. Still works for continuous restarts without user login.

I already tried a lot of things and ways that I found online without any luck.

The error that I get:

BdsDxe: No bootable option or device was found.
BdsDxe: Press any key to enter the Boot Manager Menu.

But then the boot manager cannot recognize any bootable device only if I insert the usb-drive. Although, if I enter to the boot menu right after the Debian installation then I can boot the debian boot.

The partitions look pretty like in the system76 article:

# parted -l
Model: WDC WDS100T2B0C-00PXH0 (nvme)
Disk /dev/nvme0n1: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  538MB   537MB   fat32                 boot, esp
 2      538MB   999GB   999GB   ext4
 3      999GB   1000GB  1024MB  linux-swap(v1)        swap

1
  • 1
    That error message comes from the UEFI firmware, so perhaps the UEFI boot variables are getting set incorrectly and the firmware clears out any non-functional boot variables automatically. The output of efibootmgr -v might be informative. If the PopOs installer allows, switch to a shell (typically on another virtual console, press Ctrl-Alt-F2) once the installation is complete but the system has not yet rebooted and run efibootmgr -v. Then run it again after the first reboot. Any differences in BootOrder and/or BootNNNN (N=number) lines?
    – telcoM
    Commented Nov 8, 2022 at 22:16

2 Answers 2

1

Also came across this issue with Debian 11 on a System76 Galago Pro (galp5). After installing Debian 11 from USB the same error ocurred:

BdsDxe: No bootable option or device was found.
BdsDxe: Press any key to enter the Boot Manager Menu.

The fix was to force grub-efi installation to the EFI removable media path (using expert mode in the installer, although there are other ways to configure this option too, see below).

Here are the relevant details from the page linked above (https://wiki.debian.org/UEFI):

However, to help support those unfortunate people who own buggy systems like this there is an option to force grub-efi installation to the removable media path too. There is a d-i Rescue Mode option to force this - if you've just installed Debian on your UEFI system but it won't boot Debian afterwards, this may fix the problem for you. It can also be selected during the normal installation run using Expert mode, or preseed users can add the following option in their configuration (for amd64, tweak the package name to suit on other architectures):

grub-efi-amd64  grub2/force_efi_extra_removable boolean true

You can also select this by using dpkg-reconfigure grub-efi-amd64. Among other questions asked, this is the one to look for:

Force extra installation to the EFI removable media path

0
0

Not recognizing the boot drive in a UEFI boot may mean that you have improperly set your root definitions in the efi file. If you're using Grub, you should check to if it has correctly identified the root drives (using either a UUID/PARTUUID or the dev name).

BTW, you don't need to use Grub to boot the system. You can boot directly from UEFI by creating your own efi file (with mkinitcpio or dracut). If you do that, you won't need to worry about your root drive, which will be recognized automatically, so long as you use GPT type 8304 instead of 8300 (an easy change to make).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .