Some time ago I installed Kubuntu 12.10 on Acer TravelMate 8572G which has Linpus LiveCD Editon v9.2 installed. When I tried to remove Kubuntu, something went wrong and I ended up with a broken Grub. Then I repaired it with Boot Disk Repair but before Linpus loads, I can see plenty of lines of errors like this:

EXT2-fs (sda1): error: ext2_lookup deleted inode referenced XXXX

How can I get rid of them? I don't want to install any other system, just left the laptop as it is with Linpus (I borrowed the laptop to do some things)

  • 5
    I'm not sure, but sometimes things like these are easily solved by a e2fsck -f /dev/sda1 (with sda1 unmounted). – Teresa e Junior Apr 14 '13 at 15:58
  • Complementing Teresa's remark: This usually means booting from a live / rescue medium. In order to avoid this need I always install a second, small service Linux which is accessible from a static boot manager configuration. – Hauke Laging Apr 14 '13 at 17:22
  • @TeresaeJunior thank you, it helped! Could you post it as an answer? – wryrych Apr 14 '13 at 18:29
  • @rrh you're welcome! I have posted an answer. – Teresa e Junior Apr 14 '13 at 18:38

Problems with deleted inodes generally can be solved with simply a filesystem check on the device umounted:

e2fsck -f /dev/sda1

As Hauke said, the easiest way to perform checks on umounted filesystems is through a Live medium.


Also you can use:

fsck.ext2 /dev/sda1

which is a specie of alias to e2fsck to e2fsck write completion information to the standard input (file descriptor 0), so that the progress of the filesystem check can be monitored.

fsck.ext2 will print a completion bar as it goes about its business.

From man pages

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.