1

I want to install pandoc package using pacman:

$ sudo pacman -Sy pandoc

but it installs only pandoc without any dependency, so I got many times an error like this:

pandoc: error while loading shared libraries: libHSx509-system-1.6.7-
HvqJCDpdRB8Fi0TjXvBw2D-ghc9.0.2.so: cannot open shared object file: No such file or
directory

I tried this command to install dependencies, but not sure it should work:

# pacman -Si pandoc

The way I see is parsing the result from

# pacman -Qi pandoc

and install all deps, but I think there's a better way. Can anybody help?

3
  • What was the exact command you used to install pandoc? I just ran sudo pacman -S pandoc and was prompted to install a boatload of packages. Nov 7, 2022 at 5:18
  • Yes, the command was sudo pacman -S pandoc. Moreover, I've already found a solution on archlinux forum, but after sudo pacman -Syu I did sudo pacman -Sy archlinux-keyring, because the first command failed to import a key, how can I close the question?
    – k1r1t0
    Nov 7, 2022 at 9:25
  • Answer your own question with the solution. Nov 7, 2022 at 10:02

1 Answer 1

1

I found a solution for my problem:

$ sudo pacman -Syu

It may fail with error like Failed to Import PGP key or something like that, to solve it I run:

$ sudo pacman -Sy archlinux-keyring

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .