2

When streaming videos on YouTube using firefox-esr and firefox, the video playback is choppy with an uneven frame-rate. CPU utilisation is high; 20% - 25% when streaming a 4K video on a Ryzen 5800X, as reported by tops. Internet connection is strong with 80Mbp/s.

OS: Debian 11 | CPU: Ryzen 7 5800X | GPU: AMD Asus ROG Strix 6900XT

3 Answers 3

9

I'm writing this as I've just gone through hours of trial and error to find the answer; the problem presented itself after re-installing Debian 11, for whatever reason.

Problem: YouTube video playback in firefox and firefox-esr is choppy with a very uneven FPS count. Likely accompanied by high/relatively high cpu usage (for myself, streaming a 4k video utilised 20% - 25% of my cpu according to top)

First off, in firefox-esr, going to the Settings > General, searching for "Performance", unchecking "Use recommended performance settings" and checking "Use hardware acceleration when available" had no bearing on video playback quality for me.

There is information floating around the web on how to enable hardware accelerated video decoding on various Linux Distributions. It involves installing and confirming the proper function of various backends/libraries/APIs that video players, web browsers etc. can use if they are present on the system to facilitate decoding of video formats using the machines GPU.

In my own case, I found that the mesa-va-drivers package, which provides the VA-API library, was already installed and working on the system. Furthermore this is the back-end used by Firefox >= 95 to perform hardware accelerated decoding so this was not the problem.

The Firefox Page of the Debian wiki also has a section detailing Firefox configuration options that can apparently be set to trigger hardware accelerated decoding of various media formats; setting these options as it suggests and running firefox-esr with the environment modifications it suggests had no affect on the quality of video playback for myself.

Furthermore, various blogs recommend typing "about:config" into the address bar, accepting the warning and then searching for the configuration item "layers.acceleration.force-enabled" and setting it to "true". Again this did nothing for my own video playback woes.

Finally, after reading this article, I typed "about:support" into the address bar and scrolled down to the section headed "Graphics". The first item - "Compositing" - had a value of "WebRender (software)". I typed "about:config" into the search bar, accepted the warning, searched for the configuration item "gfx.webrender.all" and changed it from "false" to "true". I then confirmed that the value of "gfx.webrender.software" was set to "false" before restarting Firefox.

Immediately YouTube videos streamed flawlessly, even when using their new 'ambient mode' which previously made the video FPS completely tank.

I really hope this saves someone the time it took me to work out how to do it, why this particular configuration item was set the way it was after a re-install is a mystery to me, but hey ho.

0

I just had this exact same problem after switching from a 1080p triple-screens setup to a 4K single-screen until I read your comment ... Catastrophic frame-rate on YT, CPU all over the place, VA-API already checked, etc.

You just made my day by giving me the answer ("gfx.webrender.all : TRUE"). Thank to you. Thank you, good sir. Thank you very much. :)

Config : i5 4590 / RX570 8GB / Debian 10 / Firefox-ESR 102

0

I solved it for myself by disabling hardware acceleration.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .