0

I am attempting to use make to build something, but it seems that /lib/modules/4.18.0-240.22.1.el8_3.x86_64/build is missing.

Previously when I encountered a similar problem with a different version kernel, the command sudo yum install "kernel-devel-$(uname -r)" worked, but this time it says:

No match for argument: kernel-devel-4.18.0-240.22.1.el8_3.x86_64

running sudo yum install kernel-devel outputs

Package kernel-devel-4.18.0-348.7.1.el8_5.x86_64 is already installed.
Package kernel-devel-4.18.0-394.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!

where it seems that it's already installed for later versions.

Another question suggests that a reboot would fix this problem, by upgrading the kernel. The kernel was purposefully downgraded because we suspect that what we are trying to do doesn't work with a higher level kernel. Additionally, rebooting the machine seemed to not fix anything.

How do I fix this, installing the correct version of kernel-devel?

1 Answer 1

1

Apparently the package can be found here. Downloaded it as an rpm, used yum remove kernel-devel do get rid of the newer installations, and then installed from the rpm package, which worked

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .