I've been trying to install Forticlient VPN on LMDE 5 (Debian Bullseye), and it failed on dependencies for libappindicator1.

Reading another post apparently from what I understood Mint removed that library, so I proceeded to install it.

sudo apt-get install libappindicator1
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'libayatana-appindicator1' instead of 'libappindicator1'
The following additional packages will be installed:
  libayatana-indicator7 libdbusmenu-gtk4
The following NEW packages will be installed:
  libayatana-appindicator1 libayatana-indicator7 libdbusmenu-gtk4
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/222 kB of archives.
After this operation, 418 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package libayatana-indicator7:amd64.
(Reading database ... 272995 files and directories currently installed.)
Preparing to unpack .../libayatana-indicator7_0.8.4-1+deb11u2_amd64.deb ...
Unpacking libayatana-indicator7:amd64 (0.8.4-1+deb11u2) ...
Selecting previously unselected package libdbusmenu-gtk4:amd64.
Preparing to unpack .../libdbusmenu-gtk4_18.10.20180917~bzr492+repack1-2_amd64.deb ...
Unpacking libdbusmenu-gtk4:amd64 (18.10.20180917~bzr492+repack1-2) ...
Selecting previously unselected package libayatana-appindicator1.
Preparing to unpack .../libayatana-appindicator1_0.5.5-2+deb11u2_amd64.deb ...
Unpacking libayatana-appindicator1 (0.5.5-2+deb11u2) ...
Setting up libayatana-indicator7:amd64 (0.8.4-1+deb11u2) ...
Setting up libdbusmenu-gtk4:amd64 (18.10.20180917~bzr492+repack1-2) ...
Setting up libayatana-appindicator1 (0.5.5-2+deb11u2) ...
Processing triggers for libc-bin (2.31-13+deb11u5) ...


Now I try to install Foticlient VPN (

sudo dpkg -i Downloads/forticlient_vpn_7.0.0.0018_amd64.deb 
Selecting previously unselected package forticlient.
(Reading database ... 273013 files and directories currently installed.)
Preparing to unpack .../forticlient_vpn_7.0.0.0018_amd64.deb ...
Unpacking forticlient ( ...
dpkg: dependency problems prevent configuration of forticlient:
 forticlient depends on libappindicator1 (>> 0); however:
  Package libappindicator1 is not installed.
  Version of libappindicator1 on system, provided by libayatana-appindicator1:amd64, is <none>.

dpkg: error processing package forticlient (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for mailcap (3.69) ...
Errors were encountered while processing:

Not sure where to go from here. This is a fresh install, following another post I first tried to install libindicator7 downloading the package, same for libappindicator1, which suggested to use already existing package on repositories, so I uninstalled everything and used the command line to install with apt-get. Same error.

Even though there's this error, Forticlient VPN installs and works, but leaves your libraries messed up, and:

sudo apt-get install -f

forces you to uninstall Forticlient. Any clues?

[Can't add decent tags due to <300 reputation here, sorry]

1 Answer 1


Try to partially repack the forticlient VPN and change its dependencies. Fire up a shell and navigate to the directory with the .deb, then do:

mkdir -pv forticlient && cp -v forticlient_vpn*.deb forticlient && cd forticlient # Create a nice clean workspace
ar vx forticlient_vpn*.deb && tar vxf control.tar.?z # Unpack the deb
# Now, edit the dependencies in control to use libayatana-appindicator1 instead of libappindicator1
tar c {post,pre}{inst,rm} md5sums control | xz -z > control.tar.xz && ar rcs forticlient_vpn_mod.deb debian-binary control.tar.xz data.tar.?z # Repack the deb

Then, forticlient_vpm_mod.deb is installation-ready.

  • Thanks a lot, very illustrative. If you can, for posterity, edit the last command and replace data.tar.gz for data.tar.xz. I confirm the tray icon to which the libayatana-appindicator1 refers works perfectly.
    – chech
    Nov 2, 2022 at 16:04
  • @chech :: done, I've rewritten the commands to make use of glob patterns and support xz archives, it also xz-compresses control now. Nov 3, 2022 at 15:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .