Since upgrading a Macbook Air (2012) from Ubuntu 22.04 to 22.10 which replaced PulseAudio with Pipewire and Wireplumber I can't seem to get any sound through the built-in speakers, and the audio seems to be constantly routed to the headphones jack no matter what. Even the DisplayPort/HDMI output doesn't output any sound.

In other words: as soon as I switch to the combined internal speakers/headphones output and plug in external speakers in the headphones jack I get a signal. The Settings app correctly detects whenever a plug is inserted or pulled out (the output's name changes), and additionally shows output activity in the bar graph whenever the speakers ("Built-in Audio") are selected and nothing is connected to the headphones jack.

Speakers work fine in other OSes -- including 22.04 -- as well as when booting the 22.10 live USB installer, so there's no hardware problem.

I've tried reinstalling pipewire and wireplumber but since then I've quickly run out of ideas. Some configuration seems to be missing. I tried to dpkg-reconfigure pipewire wireplumber but that was just a shot in the dark.

How do I troubleshoot this problem?

1 Answer 1


This problem is solved by following the instructions in an existing answer.

In /etc/modprobe.d/alsa-base.conf replace

options snd-hda-intel model=generic


# options snd-hda-intel model=generic
options snd-hda-intel probe_mask=1

When doing this I also noticed that the first line existed only as a result of a previous attempt to solve this exact problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .