I am trying to install Debian (the latest stable version with a netinst iso installed on a usb stick). I have got a (second) usb key containing all non free *.deb packages (downloaded from http://ftp.debian.org/debian/pool/non-free/f/firmware-nonfree/). I need one of them for my realtek wifi card.

At some point, the installer asks if I want to load non-free firmware packages; I insert the (second) usb key (vfat formated), and click <yes> but nothing happens. So I move on, and click <no>. Then, the installer says:

No ethernet card was detected. If you know the name of the driver needed by your ethernet card, you can select it from the list.

Well, there is no ethernet card on my laptop, but I know the wifi card : rtw88_8822ce

on a distro live, I could retrieve this:


lsmod shows this as well:

rtw88_8822c           331776  1 rtw88_8822ce

So I select the corresponding driver on the list shown by the installer but nothing happens. So I escape this part of the installation, start a shell, and try to follow this : Missing non-free firmware during Debian installation

mount /dev/sdb1 /mnt
cd /mnt/debian-bulleyes.firmware/
ls | grep realt

when entering the shell, I cannot see any dpkg command, but udpkg

udpkg -i firmware-realtek_20210315-3_all.deb

I get an error message:

(process: 7331): /var/lib/dpkg/info/firmware-reltek.postint: line 7: dpkg -trigger: not found
(updating database ...)

then I try:

udpkg --unpack firmware-realtek_20210315-3_all.deb
(reading database ...)
(updating database...)

I retry:

udpkg -i firmware-realtek_20210315-3_all.deb

but get the same error message

then I try:

udpkg --configure firmware-realtek_20210315-3_all.deb

and get this

Trying to configure firmware_realtek_20210315-3_all.deb but it is not installed 

On last thing: in /var/lib/dpkg/info/, there is a file called status; it contains something interesting:

Package: firmware-realtek
Status: install ok half-configured
Priority: optional
Section: non-free/kernel
Installed-Size: 2918
Maintainer: Debian Kernel Team <[email protected]>
Version: 20210315-3
Suggests: initramfs-tools
Description: Binary firmware for Realtek wired/wifi/BT adapters
 This package contains the binary firmware for Realtek Ethernet, wifi and
 Bluetooth adapters supported by various drivers.

* Realtek 8822CE firmware (rtw88/rtw8822c_fw.bin)
* Realtek 8822C firmware (rtw88/rtw8822c_wow_fw.bin)

I also (desesperatly) tried (in the shell) :

exec firmware-realtek_20210315-3_all.deb

Strangely, when doing that, I get back to the installer console menu (with the marker on 'detect network hardware' !)

From there, I am stuck and dont know how to address this issue.

thanks folks!

1 Answer 1


I installed Devuan (which is Debian on Sysv or Runit and did not stumble across such issue. I got rid of systemD at the same time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .