0

As of yesterday, my debian sid system on the Framework (the notebook company, that builds modular notebook) 11th gen. broke down and I urgently needed my notebook to work, so I opted for a fresh install. Framework does not officially provide support for Debian but there are community guides to either install stable, testing or sid. Which I used, to set up my former setup.

However as of today, I cannot seem to make ANY version (stable/testing/sid) to work. Eventually something fails or gets stuck through the installation process. Often it gets stuck when "selecting and installing Software", sometimes the partitioning or the software installation part or the grub installation part just simply ends telling me it has failed.

So far I tried a lot of builds, but neither worked. I got stuck or a Failed message on the same iso sometimes at different stages. The following are the ones I remembered so far and will update:

A) offical stable version (with Ethernet), which got finally stuck in "Select and Install Software" with "Retrieving file 863 of 1614 (1min 15s remaining)". But in the same installation process it failed as long as I check the "system utilities" when picking the desktop environment (like Gnome or KDE).

B) When using the unofficial stable version with (Ethernet), I just got a Failed Installation process in "Select and Install Software". In console 4 it says a lot "Unmet dependencies", "'Breaks' field", "version number does not start with digit", "Essential package with rename is dangerous".

C) The unofficial non-free weekly build didnt even recognise my ethernet connector (its via USB3) and told me while checking the disks:

Software RAID not available The current kernel doesnt seem to support software RAID(MD) devices. This should be solved by loading the necessary modules.

and straight after that

Logical Volume Manager not available The current kernel doesnt support the logical Volume Manager. You may need to load the lvm-mod module.

And eventually lead to a failed disk partition.

D) I also tried the official bookworm alpha version, but didnt work either.

E) Similar went the installation with the unofficial non-free version. This one even picked up on my AX210 and I was able to connect to my wifi.

  1. However in one try sticking with the selected "Software utilities", "Debian Desktop Environment" and "GNOME" in the Software installation the "Installation step failed" message showed up. Console 4 said a lot about LC_ALL, LC_TYPE, LC_MESSAGE not being able to be set to default locale: No such file or directory and closed with a few lines about:
... in-target: corrupted size vs. prev_size
... kernel ... general protection fault
...in-target: Segmentation fault
.../bin/in-target: warning /target/etc/mtab wont be updated since it is a symlink
... main menue ... dpkg-divert: warning: diverting file /sbin/start-stop/deamon from an Essential package with rename is dangerous
...
  1. Another try with this build got stuck on "preparing to configure cron-daemon-common(amd64)" where console 4 stated:
... kernel: ... note: dpkg[1184] exited with preempt_count 1
... in-target: E: Sub-process /usr/bin/dpkg exited unexpectedly

Can anyone give me a hint on what is going on here, is there something I shoudl do different or try? Another build I can go for? Would this rather be a hardware issue? Cheers in advance.

2
  • What is the notebook? What is your framework? How do you install it? Is the framework even installed at the time you get those errors? Commented Oct 18, 2022 at 16:00
  • I should clarify, the Framework is a Notebook of the company frame.work
    – Pratched
    Commented Oct 18, 2022 at 18:28

1 Answer 1

0

After an odyssey of different distros and Live Flashdrives iy became obvious, that my issue would be the memory. Any memtest failed big time.Maybe should have checked that earlier.

So far everything works great with a new memory stick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .